AP76 hum. Possible iffy headshell contacts.

the jewel in the crown
Post Reply
sten1969
member
member
Posts: 30
Joined: 16 Dec 2015 15:05

AP76 hum. Possible iffy headshell contacts.

Post by sten1969 » 28 May 2019 16:30

Hi all,

I've posted previously regarding a hum when using my AP76. I had some very useful earthing tips from the group which lessened the problem quite considerably. The problem seems to have returned with a vengeance though. On checking the sliding headshell contacts I've now noticed that one of them is pretty much down to the copper underneath with the silver plating nearly completely worn. A further contact isn't much better. Would I be right in thinking this could well add to the problem? Is there a way to try to remedy this? Many thanks.

lenjack
long player
long player
Posts: 1620
Joined: 23 Jun 2017 02:11
Location: Liverpool,PA

Re: AP76 hum. Possible iffy headshell contacts.

Post by lenjack » 28 May 2019 18:10

I don't think the contact being silver or copper would make the slightest difference with respect to your issue.

DSJR
long player
long player
Wales
Posts: 2856
Joined: 01 Feb 2009 20:29
Location: Suffolk

Re: AP76 hum. Possible iffy headshell contacts.

Post by DSJR » 02 Jun 2019 12:56

The headshell 'wipers' need to be straight down as viewed from the front and not tilted or bent over slightly, otherwise they will be lifted by the plastic between the strips on the carrier (I can't explain it better). It's a common issue.

Be very careful with the 'wipers' here. If you're gentle with them, it should be possible to fully sort - my own AP76 has had issues like this on occasion but it's ok right now...

lenjack
long player
long player
Posts: 1620
Joined: 23 Jun 2017 02:11
Location: Liverpool,PA

Re: AP76 hum. Possible iffy headshell contacts.

Post by lenjack » 02 Jun 2019 16:51

They would need to be quite a bit off to be a problem.

Post Reply