Sony PS FL5 Strange Problem

make believe
Post Reply
gadzuukz
Posts: 3
Joined: 06 Feb 2018 16:43

Sony PS FL5 Strange Problem

Post by gadzuukz » 13 Mar 2019 09:35

I have a PS FL5 I purchased used about a year ago and seemed to work fine until recently. In the cabinet of the entertainment system it began not lowering the tonearm and the Locked light would flash. I would need to unplug it, remove it from the cabinet, take the glass top off, turn it on move the arm around and I could after several attempts get it to reset and move to the home position and then it would work fine. Then the next day it would start again and I would need to repeat what I had done. Getting pretty tired of this, I moved my older Technics to the space and put the Sony in my office to possibly diagnose the issue. After the move to my office, it works fine, I've tested it for over a week now an no issue at all. I checked the mat alignment, level, tonearm balance etc. In my office it's setting on a box and slightly high towards the front. Might that be why it's working? Could it be a variance in AC voltage from one area to another? Would even a small drop or increase cause this issue? That's the only thing I could think of. Thanks for your assistance and great site!

nat
long player
long player
Posts: 4446
Joined: 07 Nov 2002 19:05

Re: Sony PS FL5 Strange Problem

Post by nat » 13 Mar 2019 20:34

It might be a dried lubricant issue, and moving the thing around jostled it enough to get the cycle going again. And differences in temperature might affect the lubricant also. Dried lubricants are a common problem for changers, but possibly less common in Japanese single plays, but I've seen it. It occurs to me that I've also seen cracked plastic parts, and jostling might also get them in place and working for a while.
If you are handy, opening the thing up and looking would be worth it, though there are procedures for doing it safely. If you aren't handy, getting someone else to do it might be a good idea.

AsOriginallyRecorded
senior member
senior member
Canada
Posts: 860
Joined: 26 Jun 2018 06:05

Re: Sony PS FL5 Strange Problem

Post by AsOriginallyRecorded » 13 Mar 2019 21:19

Further to nat's comments, temperature and humidity may be real issues. I have a system set up in what I think is a very nice looking cabinet, but, especially in cooler weather, find it advantageous to open the cabinet and turn on the components for a few moments to let them warm up a bit before using. The cabinet acts a bit like a cooler some times, so belts, lubes and humidity issues are all improved after a few minutes warm up. I hate to do it, but sometimes just leave one component "on" to provide a wee bit of heat in the cabinet if anticipating using the system soon. Proper lubrication and maintenance are, of course, always a good idea. Good luck on what would appear to be a simple problem, hopefully with simple solutions. [-o<

gadzuukz
Posts: 3
Joined: 06 Feb 2018 16:43

Re: Sony PS FL5 Strange Problem

Post by gadzuukz » 13 Mar 2019 23:00

Thank you all! I did open it to a certain degree, removing the metal case around the unit and didn't see anything that stood out. I try the warming technique and see although it may be warmer in the living area than my office..I'll set my hygrometer / thermometer in both places to check. Best to all! Zuukz

Post Reply