DP-37f spins backwards slowly

deeply dp
Post Reply
colklink77
Posts: 1
Joined: 19 Aug 2018 04:10

DP-37f spins backwards slowly

Post by colklink77 » 26 May 2019 00:16

Hello all,

This is my first post on VinylEngine, but I've been a long time lurker. Typically issues that I've had with turntables haven't been too difficult resolve, but this Denon that I picked up for 10 dollars is an entirely different beast. Hopefully one of you folks has an idea of where I can go next with it.

When I power it on, I get no lights and the controls do not respond. The platter just spins backwards slowly in pulses. I started doing some troubleshooting, but didn't get all that far. I'll link the service manual at the bottom of this post. So far I've done the following

1. Tested the transformer out of circuit.
2. Tested D6,7,8,and 9 - Tested good
3. Took IC10 and IC11 out of circuit. When they are out of circuit, I'm getting around 17v at their input pin hole (Pin 1 for IC10, Pin 3 for IC11)
4. Tested IC10 and IC11 out of circuit using a 12V power supply. Both output 5v and -5v respectively
5. Soldered IC10 and IC11 back into circuit, but did not solder their output pins. When I read their output pins while disconnected, they read 5v and -5v respectively
6. Tested voltages at IC10 and IC11 when they are connected on all 3 pins, they are as follows
IC10 input pin (pin 1) is reading 13.6v, manual calls for 10v
IC10 output pin (Pin 2) is reading -1.6v, manual calls for 5v
IC11 input pin (pin 3) is reading -4.5v, manual calls for -10v
IC11 output pin (pin 2) is reading -1.9v, manual calls for -5v

I'm not sure where to go from here. Obviously something up circuit is causing an issue with these readings, but I'm not sure what to look at next, this is a bit complicated for my skill level. I've read that an IC could be to blame, but I'm not sure how to test them if they're not even getting the right voltages. Any input would be helpful!

https://www.vinylengine.com/ve_download ... ice_en.pdf

Post Reply