PS-X50 Issues

make believe
Post Reply
George1955
Posts: 3
Joined: 13 Feb 2015 06:42

PS-X50 Issues

Post by George1955 » 10 Dec 2019 12:32

Picked up a Sony PS-X50 - cheap - but seller claimed "working" (I kinda knew what that meant.)

Some issues - aside from dust cover hinges, proper head shell and tonearm rest - which I'll get after solving the following:

1. At first the Start Button - worked - Now it's not - won't light - won't start spinning

2. Upon power up - the speed goes to 33 by default - once you press 45 - it won't go back to 33 unless it's shut off then on again,

3. Reject does nothing at all - won't even light up.

4. Cue lever does nothing and the speed indicator window is dark (this may be grease and a bulb)

When the platter did start - 33 was right on and 45 was a bit slow - I used a cardboard strobe - the robins one

I downloaded the service manual and I think to start with recapping - I have all the caps on hand - but - I don't want to waste all the time if that isn't the cause of the startup and non responsive buttons

any tips certainly appreciated and a thank you in advance

G

vongoosewing
United States of America
Posts: 1
Joined: 08 Jan 2016 14:35
Location: Tacoma, WA

Re: PS-X50 Issues

Post by vongoosewing » 15 Dec 2019 05:58

Start by opening it up and cleaning all the switches with contact cleaner. Clean them and switch them off and on a lot of times. Let them sit for a couple hours and go back and repeat. I have one of these and it took a lot of patience to get the switches clean but once I did I was very happy with the table.

George1955
Posts: 3
Joined: 13 Feb 2015 06:42

Re: PS-X50 Issues

Post by George1955 » 15 Dec 2019 17:36

vongoosewing wrote:
15 Dec 2019 05:58
Start by opening it up and cleaning all the switches with contact cleaner. Clean them and switch them off and on a lot of times. Let them sit for a couple hours and go back and repeat. I have one of these and it took a lot of patience to get the switches clean but once I did I was very happy with the table.


Great -I hope it isn't more than that - will report back!

AldogFresh
United States of America
Posts: 1
Joined: 07 Jan 2020 00:33

Re: PS-X50 Issues

Post by AldogFresh » 07 Jan 2020 04:11

Did it work? I have a PS-X55 with similar issues.

Post Reply