Page 1 of 1

Sony Turntable PS-LX300H making a humming noise

Posted: 28 Apr 2019 18:38
by iowafightfan
I have a Sony turntable that I got recently. I noticed it was making a low humming noise, like a ground noise, that got much louder whenever I touched the tonearm. It gets REALLY loud if I remove the head shell completely.

I opened up the bottom and found that the leads coming out of the tonearm where all there and connected securely, except the black ground lead. It is connected to the board in the rear of the turntable, where the RCA cables are also soldered, but the end I assume goes down into the tonearm itself, is not connected to anything.

Where can I connect this to? Where should it go?

Any help is appreciated. I will see if I can get a picture up in the reply.

Re: Sony Turntable PS-LX300H making a humming noise

Posted: 28 Apr 2019 18:41
by iowafightfan
Here is a picture:

Re: Sony Turntable PS-LX300H making a humming noise

Posted: 29 Apr 2019 00:52
by musicmn
Hi iowafightfan, I did get your PM so I'll try to help you out here. Sometimes that black ground wire will be attached to a triangular metal piece inserted into the tube where the tonearm wires are existing. Use a bright flash light and take a good look down inside that tube for this metal piece. If you can see one gently pull it out and then solder the wire back to it and reinsert it back into the tube. That should eliminate the hum. Now sometimes that wire runs all the up to the gimble where it can be attached somewhere inside the gimble. Or it can even go all the way to the collar at the end of the tonearm tube where it could be attached to the very small screw on the underside of the tonearm tube. If you don't see a metal piece down inside the tube where the tonearm wires exist. Then I would try to solder that wire to either that large C clip or even that brass housing. Hopefully that will eliminate that dredded hum. I use a lighter to burn the coating off that thin wire then I use my finger nails to strip the burnt coating off until I see clean bright bare wire. Then tin the wire with your soldering iron and solder before you attach it. I hope this helps.

Re: Sony Turntable PS-LX300H making a humming noise

Posted: 29 Apr 2019 01:43
by iowafightfan
Thank you for the response. Great information as always.

So, I got the tonearm disassembled, and several inches up, I see no sign of the black wire. So, this leads me to believe that the metal piece you described dropping inside of the tubes must be the method this tonearm uses for grounding. I think it's safe to say it doesn't go up the tube very far.

Re: Sony Turntable PS-LX300H making a humming noise

Posted: 29 Apr 2019 02:15
by lenjack
Are the headshell and cartridge installed? If so, make sure the headshell is secure. Also, check the wires inside the headshell, to make sure they are properly attached. Look closely, as they can look secure, and not be.