Sony PS-Q7 unstable audio

make believe
Post Reply
waldemar
Posts: 3
Joined: 17 Aug 2012 03:09

Sony PS-Q7 unstable audio

Post by waldemar » 28 Apr 2019 11:32

Hoping someone with more knowledge of electronics can help. I have a Sony PS-Q7 - truly lovely little table, great for forays to check out used vinyl. It works, other than the audio (similar to someone in an older thread). Audio out of the headphone jack slowly wavers from listenable to inaudible, with L/R choosing their own path of audibility. When something is plugged in to the back there's just a massive hum from the headphone jack. Also, when it's pretty much inaudible, touching metal on the chassis gets rid of an otherwise present hum.

This is an AEP model, pre 520xxx SN, so apparently a separate EQ board with the audio electronics. My initial thought is a capacitor which has become unstable, but since I'm a dabbler rather than a pro, wanted to see if anyone had guidance they could offer.

Thanks in advance for reading this and offering whatever help you can.
Waldemar

waldemar
Posts: 3
Joined: 17 Aug 2012 03:09

Re: Sony PS-Q7 unstable audio

Post by waldemar » 02 May 2019 03:34

In case it helps someone else, a post in another thread from @alighomash was exactly right. The problem was with the relay on the back audio jack board.

Pulled the cover, discovered the rear jack was held by one fairly accessible screw, popped off the relay cover (razor knife was the charm here), used a clean US dollar bill to clean the contacts after some non-residue contact cleaner spray, and all is wonderful in micro-Sony-turntable land. Thank you!

Post Reply