Page 1 of 1

PS-X65 platter won’t stop turning

Posted: 28 Mar 2019 18:45
by Tikijason
Hi All,

This is my first post. I just got a beautiful PS-X65 for $50 because the previous owner said it was broken. I was able to resolve the issue it had (tonearm wasn’t lifting and buttons were unresponsive) by cleaning, lubricating, and exercising the tonearm lift and making sure the cue cam was in the right place. I see no broken wires or bad solder joints inside, all capacitors look great visually, and it plays beautifully. All functions now work...except for the motor on/off switch. The platter starts to turn as soon as the power button is pressed and it continues to turn until the power is turned off. I have downloaded the user and service manuals and read the threads I found at this site, which were really helpful, but I can’t figure this problem out. I have cleaned the button and microswitch beneath it. My multimeter shows that the button itself is working. Every other function seems normal. Any ideas? TIA, Tikijason

Re: PS-X65 platter won’t stop turning

Posted: 29 Mar 2019 22:06
by Tikijason
Hi All,

Fixed my problem! I decided to recap C101 and C102 just for the heck of it. When I removed the PCB to do so, I noticed two pins on IC106 had no solder on the pads (pins seven and eight). Checking the manual, pin seven controls motor the “start/stop” button! It looks like someone had worked on the PCB before, and that idiot unsoldered these two pins for some reason. I resoldered them and all functions work normally, including the motor switch!

The first advice I read in these forums was to recap C101 and C102 *before anything else* is attempted. My capacitors were in great shape, but I replaced them anyway. In the process of doing so, I solved the problem I was more concerned about. Funny how that happens. Indirectly, great advice.

Thanks to all of the awesome folks who contributed to the other forums I’ve been reading on this site! They were a huge help to me!