Pioneer Sx-636 left channel issue

amplifiers, receivers and loudspeakers
Post Reply
the_object
member
member
United States of America
Posts: 26
Joined: 31 Dec 2018 15:29

Pioneer Sx-636 left channel issue

Post by the_object » 19 Jun 2019 04:46

So a few weeks back I turned on the receiver and the left speaker made a terrible humming noise and you could see the woofer getting sucked in and then pushed out. Turned it off, tried a couple more times, same thing. Unplugged it, popped the cover and looked for any visual issues; fuse, cap, etc., nothing. Sprayed some deox in the A speaker button. Connected a different set of speakers and no issues. Swapped the woofer from the left speaker into the right and it was all crackly so I figured it was southbound. Found a replacement on ebay,connected it, no issues. Been using it 5-8 times over the past 2 weeks and no issues. Well tonight turned on the receiver and same issue. Connected a different speaker, same thing. Moved to the B set of speaker connectors, same thing.

Anything specific that I can check or look for? Is this a common problem with older receivers?

Thanks for any advice!

Tinkaroo
vinyl addict
vinyl addict
Canada
Posts: 7454
Joined: 04 Feb 2011 20:00
Location: Pixie Hollow by The Bay

Re: Pioneer Sx-636 left channel issue

Post by Tinkaroo » 19 Jun 2019 10:26

You may want to try cleaning "all" of the selector switches and pots thoroughly before you look for other issues.The tape monitor switches and main source selector can sometimes get gummed up.

Do you have the same issue with other sources besides phono?
Is it worse on one source or another?

the_object
member
member
United States of America
Posts: 26
Joined: 31 Dec 2018 15:29

Re: Pioneer Sx-636 left channel issue

Post by the_object » 19 Jun 2019 14:23

Doesn't matter what the selector switch is on. I took some voltage readings at the speaker terminals and can see the right channel holds steady on both A & B but left channel voltage is all over the place. Then later on last night it normalized and then this morning it's happening again.

Alec124c41
vinyl engineer
vinyl engineer
Canada
Posts: 23142
Joined: 28 Oct 2002 03:24
Location: North of Toronto, Canada

Re: Pioneer Sx-636 left channel issue

Post by Alec124c41 » 19 Jun 2019 15:01

This could be an issue in the power supply.

Cheers,
Alec

the_object
member
member
United States of America
Posts: 26
Joined: 31 Dec 2018 15:29

Re: Pioneer Sx-636 left channel issue

Post by the_object » 19 Jun 2019 16:09

Anything specific I can test to confirm?

Alec124c41
vinyl engineer
vinyl engineer
Canada
Posts: 23142
Joined: 28 Oct 2002 03:24
Location: North of Toronto, Canada

Re: Pioneer Sx-636 left channel issue

Post by Alec124c41 » 20 Jun 2019 04:28

At this point, I find a good technician.
You can find a service manual at our sister site, HiFiEngine.com
https://www.hifiengine.com/manual_libra ... -636.shtml

Cheers,
Alec

Post Reply