Having problems with my set up ..

amplifiers, receivers and loudspeakers
Post Reply
mojo1970
Posts: 2
Joined: 26 Sep 2017 16:33

Having problems with my set up.....

Post by mojo1970 » 14 Nov 2017 23:10

Hi i'm pretty new to vinyl and i'm struggling with my set up.
My turntable is a Audio -Technica AT-LP120 USB and my Amp is a Marantz pm6006 with book shelve Wharfedale 9.1 diamond speakers. I've connected the speakers to the amp and the turntable to the amp however i have no sound coming through the speakers i can very faintly hear the music from the stylus......like i say I'm all new to this....I'm i missing something??? Any Help would be much appreciated.

musicmn
long player
long player
United States of America
Posts: 2124
Joined: 02 Jan 2012 23:05
Location: Milwaukee Wisconsin

Re: Having problems with my set up.....

Post by musicmn » 15 Nov 2017 00:57

Hi mojo, both the marantz pm6006 and your AT lp120 have built in phono pre amps. This means you have a couple of choices hooking up that turntable. One way is to hook the turntable up to the phono input on the marantz pm6006 but you must turn off the built in phono pre amp in the AT lp 120. Otherwise you will over load the pre amps and have nothing but distortion from your speakers. Another way is to hook the AT lp120 to a line level input like the CD input, tuner input ect. If you opt for this set up then leave the pre amp built into the AT lp 120 on so it will boost the signal from the cartridge through the marantz to the speakers. You can experiment with with both hook ups and see which one you like best. I hope this helps.

mojo1970
Posts: 2
Joined: 26 Sep 2017 16:33

Re: Having problems with my set up.....

Post by mojo1970 » 15 Nov 2017 11:28

Thanks i'll give it a go.....

Post Reply