Gyrodec MKI power adapter output

a space odyssey
Post Reply
Giovanni68
member
member
Posts: 58
Joined: 11 Nov 2016 13:07
Location: Capri - I T A L Y
Contact:

Gyrodec MKI power adapter output

Post by Giovanni68 » 11 Apr 2018 18:14

This seems like an odyssey, I sent the Rega RB300 to rewire, removed the Linn LVX, mounted the Rega, tune the VTA, put on the old belts (still have to order new ones) and plug the transformer in the AC outlet but nothing, the green light doesn't turn on, I checked the output with a tester but it only shows a couple volts, does anybody know what the output should be and what can I eventually check to put it back into working conditions?

Thank you


Giovanni

GyroSE
member
member
Sweden
Posts: 229
Joined: 25 Apr 2012 09:57

Re: Gyrodec MKI power adapter output

Post by GyroSE » 12 Apr 2018 07:52

Giovanni68 wrote:This seems like an odyssey, I sent the Rega RB300 to rewire, removed the Linn LVX, mounted the Rega, tune the VTA, put on the old belts (still have to order new ones) and plug the transformer in the AC outlet but nothing, the green light doesn't turn on, I checked the output with a tester but it only shows a couple volts, does anybody know what the output should be and what can I eventually check to put it back into working conditions?

Thank you


Giovanni
Hi Giovanni,

How old is your GyroDec and do you know if it has been in storage for many years?

Maybe the best thing to do is to get in touch with Michell directly as they probably know what to do.

Giovanni68
member
member
Posts: 58
Joined: 11 Nov 2016 13:07
Location: Capri - I T A L Y
Contact:

Re: Gyrodec MKI power adapter output

Post by Giovanni68 » 12 Apr 2018 08:44

I bought it used two years ago, used it for a little then dismantled till I decided to rewire one of the tonearms so it was working till then, dunno what might that be, will try and contact Michell too but I wish somebody here can tell me which voltage should I measure off the three pins off the power adapter.


Thank you

Post Reply