the home of the turntable

Pioneer SX 9000 Help

the final frontier

Pioneer SX 9000 Help

Postby Nicklove » 14 Jul 2017 16:53

Hi all, just got my hands on this set up. Pioneer sx 9000 receiver, JVC AL-FQ555BKX turntable, with Sansui sp 2500 speakers. It belonged to my parents so I know it was kept in good shape. I set it up and everything works except the connection from the turntable to the receiver. It was working for one day and now it seems the connection is bad. Ive tried Phono 1 and 2 and also the Auxiliary jacks. IM getting some signal but the volume has to be really high to even hear it. Whats the best course of action bearing? Thanks in advance for your help.
Nicklove
 
Posts: 3
Joined: 12 Jul 2017 15:17

United States of America

Re: Pioneer SX 9000 Help

Postby macnoob » 16 Jul 2017 00:29

Did some switch on the receiver get moved? Possibly a MM/MC switch (likely should be MM) or a tape monitor switch?
macnoob
long player
long player
 
Posts: 1068
Images: 1
Joined: 09 Apr 2014 03:07

Canada

Re: Pioneer SX 9000 Help

Postby Nicklove » 16 Jul 2017 13:10

I dont think so, more like a bad connection. Thanks.
Nicklove
 
Posts: 3
Joined: 12 Jul 2017 15:17

United States of America

Re: Pioneer SX 9000 Help

Postby Alec124c41 » 17 Jul 2017 14:48

You could try cleaning the selector switch with Deoxit.

Cheers,
Alec
Keep them spinning.
User avatar
Alec124c41
vinyl engineer
vinyl engineer
 
Posts: 20714
Images: 76
Joined: 28 Oct 2002 04:24
Location: North of Toronto, Canada

Canada

Re: Pioneer SX 9000 Help

Postby Nicklove » 17 Jul 2017 17:09

So I took it apart over the weekend and discovered a blown fuse. I replaced all three and one of them is already blown out. I brought it to a repair shop, thanks for the help though.
Nicklove
 
Posts: 3
Joined: 12 Jul 2017 15:17

United States of America

Return to Pioneer