My Pioneer PL-707 story and issues

the final frontier
Post Reply
user05
junior member
junior member
Zimbabwe
Posts: 7
Joined: 15 Mar 2019 10:13

My Pioneer PL-707 story and issues

Post by user05 » 22 Apr 2019 14:43

Hello all,

About 2 weeks ago I bought this beautiful example of 1983 Pioneer PL-707 on a Japanese auction. It arrived in the UK promptly and in great condition. Came with the original Pioneer PC-6MC High Output Moving Coil cartridge which looks unused and sounds extremely well, at least compared to AT120 with AT3600 cartridge I tried for few days and returned due to audible motor sound and a warped platter. The Pioneer's sound is much more detailed, lively, with clean higher notes and tight bass, vocals are also lovely, I'm starting to understand why people invest so much in good MC cartridges.

Full info and tech specs for those interested:

https://www.vinylengine.com/library/pio ... -707.shtml


It's currently paired with a Technics SU-7700 amp for the full retro look and a pair of Wharfedale Diamond 225 bookshelfs, apologies for a lack of whole set photo but we're redecorating the house right now and it's a big mess. Being a Japanese import it's running through a small 230-100V step-down converted integrated in a plug. Some spec

I'm extremely happy with apart from a couple of issues that needed addressing:

1. It would play 45RPM records perfectly but the 33RPM speed wasn't working - Quartz Lock was blinking and the speed was fluctuating heavily. Worried it might need a full recap or something even worse I tried the good old cleaning first. There are two surface mounted pots for adjusting the speed on the main board, one for 33 and one for 45. I sprayed them with some contact cleaner, turned few times, then readjusted the speed using a strobe disc found on Vinylengine and it's now working perfectly.

2. Auto functions don't work too well, the arm movement is choppy and it often lands just before the arm rest. I cleaned some old grease from the rack and pinion gears and ordered a replacement new belt as the 35yr old one inside is loose.

3. Arm weight adjustment is weird and doesn't work. Recommended tracking force for this cart is 2.0g. I follow the instructions by adjusting it until the arm so floats horizontally, rotate only one part until the markers show 0 by holding the adjustment screw it in position, then rotate the entire counterweight to 2.0g mark, all good there.

Some records play fine, some have a lot of distortion on louder parts as if the needle bounces a lot, antiskating set to 2.0 causes the needle to slide out of the lead-in groove and it bounces off the track if I sneeze too close to it. So I bouth a cheap scales on ebay and tested it with few coins, it seems to be calibrated accurately. With the arm set to 2.0 on the counterweight the scale shows around 1.1g. To track at 2.0g I need to effectively set the counterweight to 2.75g, to track at 1.75g the counterweight needs to be at 2.5g mark.

After setting the force using scales all records play fine, no more distortion, no more sliding off the lead-in groove and I can walk next to the turntable without causing the needle to bounce. What could be causing this issue? Is there something wrong with the arm or am I just balancing it incorrectly? Should I worry or just use the scales and ignore the counterweight?

And one more question - what kind of grease should I use for the arm gears? Preferably available from Amazon UK or ebay preferred.




https://i.ibb.co/Hrrtvzm/20190418-21302 ... 8f6e60.jpg
https://i.ibb.co/sRfDb6D/Capture.jpg
https://i.ibb.co/Sw8hYWB/image-thumb-pn ... 1bb9dd.png

Post Reply