Armboards

light fantastic
Post Reply
Notraddad
Scotland
Posts: 3
Joined: 03 Sep 2019 23:05

Armboards

Post by Notraddad » 09 Nov 2019 20:11

I have a heavy armboard with 3 holes. When I try to mount an RB 300 arm it leans too far over so the platter is only about 2mm from the top plate on the right side. I have considered reducing the circular piece underneath that is weighted. Does anyone know if it is full of lead shot that would roll out if I were to drill into it? It also seems impossible to get the substantial arm cable to go through the appropriate slot. In particular as the cable exits below the honeycomb chassis. Also, the hole in the board is offset to one corner...Is that to accommodate a 12" arm?

wine man
junior member
junior member
Great Britain
Posts: 15
Joined: 03 Sep 2019 21:33

Re: Armboards

Post by wine man » 11 Nov 2019 19:02

A Rega arm requires just one hole in the board for the central pillar & cable. Each PT board is machined and weighted specifically for both the fixing and geometry of each arm. It sounds as if you are trying to mount the RB300 into a non - Rega board (it definitely shouldn't have 3 holes). Where did the armboard come from?

Cloudbase
member
member
Posts: 208
Joined: 18 Jan 2016 21:32
Location: Lincolnshire

Re: Armboards

Post by Cloudbase » 11 Nov 2019 20:22

I think the Rega 3 point thingy is used as a spacer so it can be used on the TT but usually just bolt the arm direct to the armboard.

If your TT is an Anniversary where the platter floats on the same springs as the armboard then adjust the "sleds" to balance the weight of the arm/platter including the cartridge as well.
I havnt owned anything other than a LPT (no springs) or an Anniversary so cant comment on other models but arnt the platters unsprung on those turntables?

As for the weights on the armboard, they can be removed. More info on what equipment you have would help.

Notraddad
Scotland
Posts: 3
Joined: 03 Sep 2019 23:05

Re: Armboards

Post by Notraddad » 11 Nov 2019 22:47

It appears to be a PT Too from the descriptions on this site. With sprung chassis and black power supply. They collar with the 3 holes that match up with the ones in the armboard for the fixing screws is a spacer and it was too high. I think I may try fixing it just using three large washers I bored out to fit the arm & I'll probably just run the cables out of the hole in the base.

wine man
junior member
junior member
Great Britain
Posts: 15
Joined: 03 Sep 2019 21:33

Re: Armboards

Post by wine man » 11 Nov 2019 23:17

The rear of the armboard (where it fits to the sub chassis) should have a small rectangular cut out for cable exit - I owned a PT2 and had both Rega and SME boards, both had this feature. If you are struggling I would strongly suggest getting a knowledgeable dealer to sort this for you, PT decks need correct set up to give of their best.

Notraddad
Scotland
Posts: 3
Joined: 03 Sep 2019 23:05

Re: Armboards

Post by Notraddad » 12 Nov 2019 01:17

There is small slot wineman. However, as each cable is about 1/4" thick and the bottom of the threaded arm base protrudes about an inch, the cable would need to be bent up quite severely and would restrict any free movement in the suspension. I may look at replacing the heavy cable with some very thin silver wire that I have. I'll sort it myself.

Post Reply