PT TOO power supply issues

light fantastic
Post Reply
P700DEE
member
member
England
Posts: 160
Joined: 03 Jul 2012 09:08
Location: Egerton Kent
Contact:

PT TOO power supply issues

Post by P700DEE » 05 Oct 2018 16:32

So having had my PT1 which was upgraded in about 86 to PT Too spec I finally have a power supply issue. The motor does not turn without help for 33 and just vibrates for 45. Quick check with a multi tester does not give 110V
Which capacitors are most likely to have gone? Where should I test for the voltages to check more accurately? Advice ? Thanks

abril
long player
long player
Georgia
Posts: 2536
Joined: 13 Oct 2002 20:48
Location: Republic of Georgia/Cornwall

Re: PT TOO power supply issues

Post by abril » 12 Oct 2018 17:35

Have you got voltage at both coils?Presumably red/black and blue black
Mains voltage

consonance
United States of America
Posts: 1
Joined: 02 Sep 2019 20:50

Re: PT TOO power supply issues

Post by consonance » 22 Sep 2019 01:18

I have a similar situation.
PT one "upgraded" to TOO large wood box power supply
Spins at 33.3 and vibrates at 45.
Voltage on the din socket pins at 33.3 is 92.4 Pin 1/92.9 pin 4 to ground (pin 2) 128.9v pin 1 to pin 4.
Voltage at 45 is 28.4 Pin 1/30.5 pin 4 to ground pin 2 42.3v pin 1 to pin 4 Obviously too low to turn the motor.
115 mains voltage

The two large power supply capacitors appear OK
are the physically small electrolytic capacitors potentially in need of replacement or is this a crystal issue?

any help would be appreciated. thanks

Post Reply