project xtension 9 stops

carboniferous
Post Reply
pakyapunter
India
Posts: 2
Joined: 17 Oct 2018 17:41

project xtension 9 stops

Post by pakyapunter » 17 Oct 2018 17:59

hi friends ,I have a project xtension 9 turntable with s shape tone arm I am having trouble with tt as it stops spinning randomly .
1)sometimes all the 3 lights are on that is the start/stop ,33rpm,45rpm
2)sometimes only green light start/stop is on sometimes the 33rpm blue light goes on but tt stops.
end result of all is tt stops then sometimes it starts by just pressing the start button,sometimes I have to cut the main switch then on again n it starts
my speculation is
1)adapter is at fault? it's a 15v 1.6amp adapter (also there r no chances of voltage spikes as I have APC online ups which is v.good n no other equipmen has any problem)
2)start switch problem?
3)motor problem??
I wrote to project guys twice but no reply till now so guys help seriously needed.thanks in advance

R_Polli
member
member
Germany
Posts: 27
Joined: 21 Oct 2018 10:59
Location: Duisburg, D, NRW

Re: project xtension 9 stops

Post by R_Polli » 22 Oct 2018 11:56

That sounds like a problem with the control electronics. Have you ever tried another power supply and/or tried it without the APC?

Big Al
member
member
Posts: 85
Joined: 03 May 2008 19:44
Location: UK

Re: project xtension 9 stops

Post by Big Al » 22 Oct 2018 20:19

All three lights on at the same time? Surely a problem with the control unit.

pakyapunter
India
Posts: 2
Joined: 17 Oct 2018 17:41

Re: project xtension 9 stops

Post by pakyapunter » 22 Oct 2018 20:36

Thanks for the reply friends, have sent the tt to the dealer let's see what he has to say.

runecarve
Canada
Posts: 1
Joined: 15 May 2019 15:17

Re: project xtension 9 stops

Post by runecarve » 15 May 2019 15:56

Hello,

I am experiencing the same problem, so I am wondering what the resolution was? I just had the speedboard replaced under warranty, but that seems to have increased the number of stoppages. Yesterday, it stopped 5 times in a row through a duration of 90 minutes.

The Project Carbon Deluxe that I have does not have issues when connected to the same power conditioner or other outlets in the house.....

Post Reply