Page 1 of 1

Dual CS 616-Q tonearm raises randomly

Posted: 23 Dec 2009 23:06
by retrohound
Hello all,

I've got a Dual CS 616-Q that I bought for $40 about a year ago. The tonearm will just randomly lift up while it's playing a record. I have to get up and hit the 'lift' button to lower the arm back to the album. What's going on? I have several hundred albums, but I had a Kenwood KD-74F turntable for over 20 years and it's a completely different set-up with a tracking arm, so I don't know the equipment set-up very well for a standard turntable. Any thoughts?

Posted: 24 Dec 2009 07:43
by romanose
Hi retrohound,
I've printed out the service manual for your deck. It looks like it's all electronically controlled. If I'm interpreting it right. I'm not all that up on circuitry, but maybe I can help.

The circuit looks like the lift is controlled by mc 6805. I would guess the chip is activated by the lift switch, in the little box on the diagram by the chip. Or by the tone arm switch on the right hand side of the diagram. I gather Lift M3 is a solenoid that sucks down to lower the tone arm. If I'm right several things could be going on. The lift switch or wiring could be intermittent as well as the tone arm switch or wiring. The main chip MC 6805 could be going out or the transistors tr33 or tr36 could be going too. Think about when it does it is the deck hot or cold? Temperature will cause a solid state device to fail when they are weak. Sometimes heat sometimes cold. Sometimes the solder will get old and be intermittent.

The best place to start though is to reseat the plugs. It could be something as simple as corrosion on pin 3 or 4 of BR 02. Look on the picture of the control board in the upper right hand corner and you will see BR 02. Gently remove it from the board and reinstall it. Then try it and see what happens. I'll try and help as much as I can, but I have never seen one of these before. If someone with more knowledge comes along we can both learn something. lol

Good luck.

Regards. Ron.

Posted: 24 Dec 2009 15:38
by retrohound
Thanks for the tip. I was assuming it was something mechanical. Electrical never even occurred to me.

Posted: 25 Dec 2009 20:20
by 3rd_Ear
The ┬ÁProcessor of this line of Dual turntables is permanently checking the speed of the platter.
When the speed does not fit into predefined margins, it is programmed to raise the tonearm.
Apart from problems with corroded contacts, sometimes just the grease of the motor bearing is too sticky. Otherwise you'll have to check, if any obstacle interferes with the rotating platter.

Posted: 26 Dec 2009 02:48
by romanose
I kinda expected that was what lm01, 2, 3, and 4 were for. I also expected the motor was permanently lubricated like the cs 5000. That's why I didn't mention it, but that could easily be the problem as well 3rd ear. If it was belt drive, that would have been my first suspect.
Regards. Ron.

late reply.....

Posted: 22 Jan 2011 13:56
by kl_bob
Hi,

I have just re-activated my old Cs 616Q after it has been unused for two years or so...
..I have got now the same problem described here and I will try out what is suggested...

best regards
Klaus

Posted: 24 Jan 2011 03:13
by Alec124c41
616Q service manual, Eng. Fr. Ger.
https://www.vinylengine.com/library/dual/cs-616q.shtml

Cheers,
Alec

Re: Dual CS 616-Q tonearm raises randomly

Posted: 10 Jun 2019 14:59
by thierry74
I had the same problem, and found the solution in this answer by Japi Roelofs: viewtopic.php?f=37&t=79886#p788720.

The cause of my problem was the same:
Then I noticed some pretty bad tarnish on the little microswitch that engages the lift solenoid. It looked really black, so I cleaned the contact points using a sliver of pencil eraser, followed by some contact cleaner. Part # 69 "Microschalter" (microswitch) in the exploded view drawing, part # S1 in the wiring scheme.
I cleaned it using a piece of cloth dipped in alcohol that I rubbed between the contacts. The black deposit went away immediately, and my turntable works wonderfully since then!