Loud pop when starting 1249

twice the fun
Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 17:02

So, just got this 1249. It looks to be in good shape. Needs re-greased I'm sure. Got a cart for it and pimple. Set up tonearm and plugged into receiver. Got a loud POP when tonearm travels from rest to play, Immediately lowered volume. Where should I look for the problem? Cart was preinstalled into the missing sleeve. Found the way it attaches to be a little weird like something was missing from the shell but it stayed in place. Everything else underneath looks OK but i am no expert on Duals. Anyone got a photo of the underside of the tonearm mount? I'm really guessing here. This is the first , I'm sure, of many issues the the previous owner did not tell me about.

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 17:51

So, I thought I'd take a picture. The sled I was sent by turntable needles.com only has the 4 pins to connect to the tabs on the head shell. The head shell seems to have a 5th tab which I assume is a ground.https://www.soloinc.com/uploads/headshell.jpg. Did I get the wrong slide? I did just deoxit but haven't retried before posting this for fear of noise again.

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 18:01

Found this in another thread " need to change the capacitor that suppresses the spark/pop at shutoff" could this be the issue? If so, where do I find the capacitor?

dualcan
long player
long player
Canada
Posts: 3563
Joined: 15 Nov 2013 23:53
Location: Sorel-Tracy Quebec
Contact:

Re: Loud pop when starting 1249

Post by dualcan » 17 Feb 2019 19:08

Hi,
The x2 spark cap is in the power switch:
DSC00019.JPG
(60.99 KiB) Downloaded 90 times
and there is also x2 some caps in the strobe box which should be changed if they are Rifa brand and cracked:
DSC00021.JPG
(55.44 KiB) Downloaded 88 times
Regards,
k

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 19:48

Ahaa! Thanks!

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 20:53

So, I got this info from another thread and tried to find these capacitors on mouser.com but frankly, it is too confusing for me. "47 and 68 nF Rifa capacitors". where can I look for these and what specifically should I ask for? My one capacitor says .068J400 and the other says PME 27/m, c2/75, gff -40/85°C. So? Stumped.

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 21:28

None looked cracked but i want to change them anyway.

T68
senior member
senior member
Sweden
Posts: 280
Joined: 11 Jul 2018 18:41

Re: Loud pop when starting 1249

Post by T68 » 17 Feb 2019 22:48

Well had you been in Europe l could have given you links to a website called Conrad where I got the two caps for my 601 which I replaced recently.
But since I understand you're in the US I think you'd better off buying them over there.
Good luck with the repair. Great table you got there!

Spinner45
long player
long player
United States of America
Posts: 3001
Joined: 01 Mar 2017 18:21

Re: Loud pop when starting 1249

Post by Spinner45 » 17 Feb 2019 23:27

Dadrepus wrote:
17 Feb 2019 20:53
So, I got this info from another thread and tried to find these capacitors on mouser.com but frankly, it is too confusing for me. "47 and 68 nF Rifa capacitors". where can I look for these and what specifically should I ask for? My one capacitor says .068J400 and the other says PME 27/m, c2/75, gff -40/85°C. So? Stumped.
0.047uf and 0.068uf - 400 volt rating.
I use 630 volt rating mylar caps for added reliability.
They're common values.

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 17 Feb 2019 23:43


dualcan
long player
long player
Canada
Posts: 3563
Joined: 15 Nov 2013 23:53
Location: Sorel-Tracy Quebec
Contact:

Re: Loud pop when starting 1249

Post by dualcan » 18 Feb 2019 01:27

Hi,
..so as a repeat from a previous posting, let's try this again...
These capacitors sit across or to ground on the power line, either 110 or 240 volts ac,
To ensure SAFETY when there is a short, these caps must be used in equipment today. Please read the following link:
http://www.kemet.com/Lists/Filestore/Ev ... andSMD.pdf
There is a reason why these caps were developed and fire or shock is primarily the reason.
I don't understand why for a bit more money anyone would not want to use the extra security.
If you order in Europe from Conrad,
0.047, 0.01, 0.068 uF originally used by Dual:
https://www.conrad.de/de/entstoerkonden ... 45650.html
From Mouser in the US:
for 0.047
There are other X and Y safety cap manufacturers as well and many more sources besides these.
I have listed Rifa Kemet, as these where the ones last used in manufacturing but any other x2 brand will do as well,
Regards,
k
https://www.mouser.com/ProductDetail/KE ... buNP7s4%3d
for 0.068
https://www.mouser.com/ProductDetail/KE ... yUvnthc%3d
from Digikey:
for 0.047
https://www.digikey.ca/products/en?keyw ... 547MR30%20
for 0.068
https://www.digikey.ca/products/en?keyw ... 71m568mr30
Regards,
k

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 18 Feb 2019 05:34

Tried to order both from Mouser on line. Their web store is broken so I will call on Monday. Digikey wants $20 to ship $3 worth of parts so I'll wait.
Thanks for all your Help. Once I get them and solder them in, I will let everyone know how it goes. Really solid machine.

T68
senior member
senior member
Sweden
Posts: 280
Joined: 11 Jul 2018 18:41

Re: Loud pop when starting 1249

Post by T68 » 18 Feb 2019 11:36

Haha, shipping always feels so eeeexxxpeeensive when ordering small stuff like these guys.
And then we have the packing... Heres how conrad shipped one little cap to me (got a lot of air for free)
conrad_pack.jpg
(81.38 KiB) Downloaded 55 times

Dadrepus
member
member
Posts: 81
Joined: 01 Dec 2016 22:01
Location: Columbia, Md

Re: Loud pop when starting 1249

Post by Dadrepus » 18 Feb 2019 16:38

Just placed my order. $7 shipping with Mouser. Funny thing, they had my account but I could not log in for some reason. I was shocked that she identified me without me giving her any info, I guess they had the phone number on file along with everything except my CC info. Scary #-o

dualcan
long player
long player
Canada
Posts: 3563
Joined: 15 Nov 2013 23:53
Location: Sorel-Tracy Quebec
Contact:

Re: Loud pop when starting 1249

Post by dualcan » 18 Feb 2019 21:24

Hi,
Have no fear "They" know more about you (and me..) than you or I know about ourselves...-some of it actually true...
Cheers,
Klaus

Post Reply