Dual 1215 speed issue

twice the fun
Post Reply
GWTWTOO
member
member
Posts: 45
Joined: 26 Sep 2014 06:56

Dual 1215 speed issue

Post by GWTWTOO » 13 Aug 2019 21:17

Hi, all! About three years ago, I bought a Dual 1215 TT from Bill Neumann, who’s really well-regarded when it comes to the servicing and restoration of Duals.

Recently, my TT starts slowly if I haven’t used it in a few days. After some fiddling around switching between speeds, I can get it to run properly. Once it’s going, it’s very accurate and it has no problem going through its automatic cycle, whether I am playing records one at a time or using the stacking spindle.

Any idea what’s going in? Thanks so much, Mark

Hugues TR4
long player
long player
Belgium
Posts: 1174
Joined: 21 Apr 2009 10:33
Location: Belgium

Re: Dual 1215 speed issue

Post by Hugues TR4 » 14 Aug 2019 15:50

Has the motor been serviced thoroughly?
If you added some oil into the motor without opening it, did you make sure you used exactly the same oil type?
I already had a problem of this kind with a chemical reaction between the different oils: motor stuck…
You will find a complete motor overhaul description in the stickies on top of this page. Not too difficult and certainly well worth it!
Cheers,

Hugh.

mrow2
long player
long player
United States of America
Posts: 3367
Joined: 25 Aug 2010 03:05
Location: San Clemente, California

Re: Dual 1215 speed issue

Post by mrow2 » 16 Aug 2019 08:56

Besides what Hugues wrote, another area to look at is the fluid movement of the speed change mechanism. There are many parts to it and if any old grease and oil remained on the mechanism the idler wheel may not swing fully into position and ride properly against the platter drum, i.e., it could slip a bit against this and also the pulley, which would affect speed. I’ve dealt with this condition on the 1019 before, but that model would be the more likely of the two to have this issue. There needs to be a decent “pinch” occurring between those points as the idler is running.

The platter drum and pulley should both be cleaned with isopropyl to remove fingerprints too. Inspect the idler wheel to be sure it is in good shape. Bill once told me that he uses very thin oil on these, but he didn’t say what type it was. But this might be as simple as re-lubing the motor (upper and lower bearings both) with thin mineral oil like what is recommended here in the section Hugues mentions (sew Mach oil) and verify that the rotor spins freely afterwards.

Post Reply