Page 4 of 14

Re: SL-DD33 sounds like s**t

Posted: 24 May 2019 07:41
by chriz74
Is there any way to check it? It seems fine looking at it.

Re: SL-DD33 sounds like s**t

Posted: 24 May 2019 08:12
by Van_Isle
Most likely not unless you have a 200 to 300x microscope and the knowledge to know what you are looking at.

However, I've experienced sloppy assembly as an issue and you can tell under lower magnification that there is an excess of glue used to mount the actual diamond.

However, since you've mentioned that the cartridge body has some corrosion on it I'd be more inclined to replace the entire cartridge. If you look around you should be able to get a new Audio Technica p-mount cartridge with stylus for $20 to $30. There were many different model numbers for these (AT90, AT91, AT92, etc) and they were sold under many different brand names. For example, Technics P34.

The other thing you could try first I suppose is to get a P-mount to standard-mount adapter (~$10) and try the cartridge out on your Pioneer.

Re: SL-DD33 sounds like s**t

Posted: 25 May 2019 14:21
by chriz74
I think the adapter is good only if you can adjust tracking. What about AT85EP ? However I am thinking of selling the two turntables and buy a plx-500.

Re: SL-DD33 sounds like s**t

Posted: 25 May 2019 14:50
by eddie edirol
I know what saturated reverb is. The RCA wires are bad and are phasing out the sound. The phasing happens when the positive and negative wires are reversed. So either the RCA wires need to be replaced, or the cartridge is wired wrong.
Im going to assume you wired the cart to the right colors on the headshell, unless the headshell colors dont match regular turntables.
Maybe wiggle the RCA wires all the way to the amp and see if you can find the short. Its usually the wires that go bad on Technics first.

Re: SL-DD33 sounds like s**t

Posted: 25 May 2019 17:10
by chriz74
I didn’t do anything with the shell. The RCAs you say? I don’t know. How do the RCAs also cause skating?

Re: SL-DD33 sounds like s**t

Posted: 25 May 2019 23:53
by kabelectro
it could be that the cueing bar that lifts and lowers the tonearm is not going all the way down causing the arm to drag. check to make sure that the cueing bar clears the tonearm. You should be able to see a space between the bottom of the tonearm wand and the cueing bar. You may also need to check tracking force with a gauge. There is an adjustment in the back of the tonearm.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 00:42
by Van_Isle
chriz74 wrote:
25 May 2019 14:21
I think the adapter is good only if you can adjust tracking. What about AT85EP ? However I am thinking of selling the two turntables and buy a plx-500.
Adapter would allow you to mount the Technics p-mount cartridge on the Pioneer to confirm it is ok.

The cueing bar tip is a good one ... check that out.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 03:22
by eddie edirol
chriz74 wrote:
25 May 2019 17:10
I didn’t do anything with the shell. The RCAs you say? I don’t know. How do the RCAs also cause skating?
RCAs dont cause skating, but I concur with kabelectro on checking the cueing bar. But now that I think about it, I think your stylus is broken off if its skating. I wonder why that would be if it was new, but thats all I can think of. That causes skating and that saturated reverb sound. You should try installing the cart from your pioneer and see what happens.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 06:39
by Van_Isle
Pioneer is half-inch mount. Technics is p-mount. That's why I suggested trying it the other way around with an adapter.

By the way, i forgot ... AT85EP would be fine.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 07:44
by eddie edirol
Van_Isle wrote:
26 May 2019 06:39
Pioneer is half-inch mount. Technics is p-mount. That's why I suggested trying it the other way around with an adapter.

By the way, i forgot ... AT85EP would be fine.
Oh jeez, I didnt read close enough to realize the Technics is a P-Mount. Cant believe I missed that in the title.

Hey Chris, how does the Technics arm feel in weight compared to the Pioneer?
Its possible that the counterweight was screwed outwards (since its a fixed weight unit) making the tone arm too light on the stylus. I know theres a screw that holds the weight that is supposed to be pre-adjusted.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 14:15
by chriz74
kabelectro wrote:
25 May 2019 23:53
it could be that the cueing bar that lifts and lowers the tonearm is not going all the way down causing the arm to drag. check to make sure that the cueing bar clears the tonearm. You should be able to see a space between the bottom of the tonearm wand and the cueing bar. You may also need to check tracking force with a gauge. There is an adjustment in the back of the tonearm.
Ok the cueing bar clears the tonearm so no problem there. Yes indeed there is screw on the back of the tonearm but there is no reference to adjust the tracking force as it’s “precisely adjusted by the factory”, so how am I supposed to fix it?

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 15:12
by chriz74
Ok I get it, I need a tester. I ordered one at amazon for 11 euros. They all seems the same item with different brand names.

Re: SL-DD33 sounds like s**t

Posted: 26 May 2019 16:44
by chriz74
eddie edirol wrote:
26 May 2019 07:44
Van_Isle wrote:
26 May 2019 06:39
Pioneer is half-inch mount. Technics is p-mount. That's why I suggested trying it the other way around with an adapter.

By the way, i forgot ... AT85EP would be fine.
Oh jeez, I didnt read close enough to realize the Technics is a P-Mount. Cant believe I missed that in the title.

Hey Chris, how does the Technics arm feel in weight compared to the Pioneer?
Its possible that the counterweight was screwed outwards (since its a fixed weight unit) making the tone arm too light on the stylus. I know theres a screw that holds the weight that is supposed to be pre-adjusted.
Yes there’s the screw. I have no idea if it was touched in the past. I ordered a digital tester to check the force. I’ll be back with results.

Re: SL-DD33 sounds like s**t

Posted: 27 May 2019 09:08
by chriz74
I also got a blank vinyl to check anti skate.

Re: SL-DD33 sounds like s**t

Posted: 28 May 2019 14:26
by chriz74
Ok, the gauge arrived. The needle force was 0,71g , I set to 1,25g. I also cleaned the old stylus and put it back. Now it sounds better but there’s more static than on the Pioneer, same record. What do you suggest?

Edit:

There’s less static using the new needle, I had to recalibrate the force as it lost 0,25g with the new one.

I guess if I should try an AT85EP or sell everything.