Sony PS-X75 Biotracer Tone arm will not drop

snap, crackle and pop
Post Reply
psychmonster
junior member
junior member
Posts: 8
Joined: 19 Apr 2010 22:34
Location: chicago

Sony PS-X75 Biotracer Tone arm will not drop

Post by psychmonster » 25 Mar 2017 15:14

I have been in an outside of this table...I have got everything to work except when auto start is depressed...the arm drifts to the right spot but will not drop...a gentle tap on the unit...(anywhere) and it will drop...no other issues...I read somewhere that this may be "old" gunk from 40 years of sitting that may be the problem...but this solution works for me ( tried to add an animated gif file (AVI) showing action but it was too big

FileFixer

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by FileFixer » 25 Mar 2017 16:27

Tonearm lifter on PS-X75 is controlled with vertical linear motor...

Try to look on service manual... maybe is motor dead or som electronics who controlled that motor?!
https://www.vinylengine.com/library/Sony/ps-x75.shtml

psychmonster
junior member
junior member
Posts: 8
Joined: 19 Apr 2010 22:34
Location: chicago

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by psychmonster » 25 Mar 2017 17:46

it is not the motor...at end of lp and / or if I stop it, it rejects and lifts properly into its cradle

chilly
member
member
Posts: 29
Joined: 10 Mar 2015 02:24
Location: Kansas City

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by chilly » 26 Mar 2017 04:34

I had this happen to my X75, I loosened the lift, and twisted the black lift back towards the rear of the player, and it worked. I think maybe the lift would get stuck on the housing.

Hope this helps.

psychmonster
junior member
junior member
Posts: 8
Joined: 19 Apr 2010 22:34
Location: chicago

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by psychmonster » 26 Mar 2017 23:09

thanks...I played with that black bar...I also lubed the bar spindle with sewing machine oil...all the way back towards the hinges will drop my tonearm...but it will not reject...it raises but my motor is too weak to start it back to the cradle over that little bump on the bar...moving it 3/4 forward works...it drops and it will reject to the cradle with enough momentum to get over that bump and hit the cradle...cools...thanks for the tip

brinsmeads
member
member
Posts: 61
Joined: 03 Feb 2012 22:19

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by brinsmeads » 24 Apr 2018 20:54

Hi, This may be a help to most arm dropping related issues.

https://www.vinylengine.com/turntable_f ... 0&start=30

brinsmeads
member
member
Posts: 61
Joined: 03 Feb 2012 22:19

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by brinsmeads » 25 Apr 2018 00:17

When you have the motor assembly stripped down, put a drop of oil on the top side of the arm lifter and work it down the shaft from the top.....by repeatedly pushing the circled arm lifter shaft end...quite often the arm lifter will be seized
Attachments
Circled is the Lifter Shaft on the PS-x75.jpg
(723.38 KiB) Downloaded 358 times

brinsmeads
member
member
Posts: 61
Joined: 03 Feb 2012 22:19

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by brinsmeads » 25 Apr 2018 06:31

Sony hardened Grease causing timing and lifting Arm Issues

Circled is the lifter pin which can be seized or partially seized

Both of these issues need addressing

The Dismantling of these components and repair is explained in the Link above
Attachments
Sony Hardened Grease with Arm Lifter Circled.jpg
(381.47 KiB) Downloaded 420 times

zxryder93
junior member
junior member
Posts: 5
Joined: 29 May 2017 21:19

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by zxryder93 » 22 Jan 2020 19:55

I recently acquired a PS-X75 and the arm won't drop, it appears locked in the raised position. It moves horizontally to the beginning of the record and just stops there with the table turning. I've read many threads about this and am trying to avoid taking things apart.

I've tried putting some oil down the post/shaft for the curved black plastic arm lift. I've read that this post can be worked up and down to get the oil downward. On mine, I can't move the lift bar at all, up or down.

So my question is, with the hardened grease problem, does that cause the lift post to lock up completely? I'm being careful not to force it too much, but it does not move at all in any direction. Should I be still be thinking hardened grease or start looking at something else? Any advice is greatly appreciated.

zxryder93
junior member
junior member
Posts: 5
Joined: 29 May 2017 21:19

Re: Sony PS-X75 Biotracer Tone arm will not drop

Post by zxryder93 » 24 Jan 2020 15:01

So I studied the pictures above of the coil cam and suddenly the light came on. The hardened grease affects the rotation of the coil cam (white plastic piece with the coils on it), and the lift post won't move at all if the cam is stuck where the ramp has lifted the post all the way up.

I opened the bottom and turned the coil cam by hand (it could only move counterclockwise, looking at it from the bottom, because it was stuck in the fully up position). It definitely felt clogged by grease, a little hard to turn. Then, fully counterclockwise (that would would be the down position for the lift post) allowed some play to push the lift bar down. It was also seized pretty good, but I was finally able to get downward then upward movement on it by hand.

So I'll have to work on grease clean up now, but I'm pretty happy I understand what is wrong!

Post Reply