help Automatic Cue not working!

snap, crackle and pop
Post Reply
elissabell98
Posts: 2
Joined: 23 Jul 2015 09:07

help Automatic Cue not working!

Post by elissabell98 » 23 Jul 2015 09:19

Hey all,
I just purchased a vintage JVC JL-F50 and I absolutely love it one problem. The tonearm won't lift even after I calibrated it. I also noticed that when I press the cue button nothing happens but I get a rather annoying buzz (it sounds as if it's coming from the timing motor). The automatic feature is kind of necessary as I like to chill when I listen to my records. When the record finishes rather than lifting it lightly scratches over my records. Please help I desperately want this to work.
Regards

Japi Roelofs
long player
long player
Netherlands
Posts: 4568
Joined: 05 Apr 2008 16:53
Location: Netherlands

Re: help Automatic Cue not working!

Post by Japi Roelofs » 23 Jul 2015 12:58

Hi and welcome to the forum,

Unfortunately there is no manual or service manual for your JL-F50 in the library.

What you describe sounds like there should be a rubber belt connecting the timing motor to the cueing mechanism. This belt may have perished. You would need to open the turntable, locate the timing motor, and see if it needs a new belt. A rubber band or an o-ring of the right size could solve your problem.

However I'm just guessing here as I have never seen your turntable's insides.
Maybe there's fellow VE members that actually own this model and can chime in.

kontrabass888
junior member
junior member
Posts: 11
Joined: 31 Mar 2010 18:57
Location: Liege

Re: help Automatic Cue not working!

Post by kontrabass888 » 31 Dec 2016 18:26

elissabell98 wrote:Hey all,
I just purchased a vintage JVC JL-F50 and I absolutely love it one problem. The tonearm won't lift even after I calibrated it. I also noticed that when I press the cue button nothing happens but I get a rather annoying buzz (it sounds as if it's coming from the timing motor). The automatic feature is kind of necessary as I like to chill when I listen to my records. When the record finishes rather than lifting it lightly scratches over my records. Please help I desperately want this to work.
Regards
I just bought a JVC jl F50 last weekend, the cue button was also defective, and the lifter doesn't work as well.
I opened the back cover and I discovered that the plastic screw to hold the switch(a small red box) which is connected with e cue button, was broken ,I replaced it with a metal screw, and I pulled the arm which to connect the lifter and the timing motor back and force few times.
And then, the problem is solved.
Attachments
IMG_20161229_163251815 copy.jpg
(241.24 KiB) Downloaded 225 times

wroadrun
Posts: 3
Joined: 14 Sep 2010 18:20
Location: Peterborough, Ontario, Canada

Re: help Automatic Cue not working!

Post by wroadrun » 13 Dec 2019 19:47

Lucky you. I have one that the timing motor is seized. Ref#91 from SM, part #EE35032-002. Where do I find one? I'll have to turn the elliptical gear to a position where I can raise and lower it manually. Kinda defeats the purpose of a full auto turntable though.
Attachments
JL-F50 Timing motor.jpg
(132.14 KiB) Downloaded 40 times

UsableThought
member
member
United States of America
Posts: 76
Joined: 14 Nov 2019 07:26

Re: help Automatic Cue not working!

Post by UsableThought » 14 Dec 2019 15:30

Japi Roelofs wrote:
23 Jul 2015 12:58
Unfortunately there is no manual or service manual for your JL-F50 in the library.
https://www.vinylengine.com/library/jvc/jl-f50.shtml

Post Reply