NAD 5120 tonearm lateral bearing

snap, crackle and pop
Post Reply
Armbored
member
member
Great Britain
Posts: 108
Joined: 19 Jan 2015 18:14
Location: Aberdeen, Scotland

NAD 5120 tonearm lateral bearing

Post by Armbored » 22 Nov 2019 16:11

Hello all,

Just wondering if anyone can help me with an issue I have with a NAD 5120. It's the round tonearm, but the bearing seems to be the issue. The arm is not following the groove, instead it just stays put and skips. Looks like there is too much resistance to pull the arm across the record. I have dismantled the bearing assembly and reassembled but there is nothing restricting the movement. When the bearing spindle is being reinserted into the tonearm pillar, there seems plenty free movement but once it seats on the metal disc (thrust pad), there appears to be too much friction between the spindle and the thrust pad. I have cleaned and re-lubed with graphite oil but friction when bottoming out the bearing seems to be the issue. Does anyone have any idea how to overcome?

Thanks for any help
Mike

nat
long player
long player
Posts: 4495
Joined: 07 Nov 2002 19:05

Re: NAD 5120 tonearm lateral bearing

Post by nat » 22 Nov 2019 21:52

Was there a ball bearing in there? Or was there a delrin or other slippery plastic thrust pad? I don't know anything about the bearing in question, but a metal thrust pad sounds rather high friction to me unless it is a single point bearing, which seems odd in a tonearm bearing, and, more cogently, if it is supposed a single point on metal thrust pad, and that's what you have, you wouldn't have all that friction.

Armbored
member
member
Great Britain
Posts: 108
Joined: 19 Jan 2015 18:14
Location: Aberdeen, Scotland

Re: NAD 5120 tonearm lateral bearing

Post by Armbored » 22 Nov 2019 23:00

Hi there,
It's an unusual design, it uses the exact same bearing (2 off) for the turntable spindle and the tonearm lateral bearing. Yes, a metal disc for a thrust pad, no ball, just the ground and polished spindle on the thrust pad. The spindle bearing runs perfectly like this, but the tonearm pillar bearing has too much friction, it's is a problem and I just can't work out why. I have tried replacing it with a piece of plastic but it's no better. I know you can get PTFE pads but don't want to shell out loads on this.
If anyone has had this experience and can advise a solution, it would be really helpful, thanks!
Mike

nat
long player
long player
Posts: 4495
Joined: 07 Nov 2002 19:05

Re: NAD 5120 tonearm lateral bearing

Post by nat » 23 Nov 2019 13:02

Is the bearing too tight?

nat
long player
long player
Posts: 4495
Joined: 07 Nov 2002 19:05

Re: NAD 5120 tonearm lateral bearing

Post by nat » 23 Nov 2019 13:08

Weird - looked at the service manual, which, unfortunately is a bit hard to read, and doesn't seem to include a lot of information, but it appears that the same bearing is used for the platter and the arm. So looking at the platter bearing might clarify things.

Post Reply