Technics SL-1700 MK2 - Problem with arm return

snap, crackle and pop
Post Reply
afrikseb
France
Posts: 1
Joined: 09 Nov 2019 17:29

Technics SL-1700 MK2 - Problem with arm return

Post by afrikseb » 09 Nov 2019 18:27

Hello everyone.

As said in title, the arm on my Technics SL-1700 MK2 won't go back smoothly. It makes this awful "clac clac clac clac" noise all the way back, as you can see in this video https://imgur.com/aNrReJx. Does someone know if it's a common problem ? I didn't find any information about it. After opening my turntable, I can see the plastics gears are ok, but there's like a resistance which causes gears to dissassemble and make this noise.

Thanks a lot for your help.

paddypaws
member
member
England
Posts: 38
Joined: 21 Nov 2018 23:04

Re: Technics SL-1700 MK2 - Problem with arm return

Post by paddypaws » 09 Nov 2019 22:03

I’d replace the belt in case it’s slipping and clean all the gears up with isopropyl alcohol and cotton buds removing all old dried up grease and re grease with a plastic safe grease such as silicon or lithium grease. Clean the rubber post that pushes against the semi circular plastic track on the bottom of the arm with a rubber restorer.

patleaver
member
member
United States of America
Posts: 124
Joined: 11 Jan 2009 02:49
Location: California

Re: Technics SL-1700 MK2 - Problem with arm return

Post by patleaver » 10 Nov 2019 05:20

There is a spur gear (smaller of the two) that often starts to fail and the mesh/cogging with the larger gear is interrupted.

paddypaws
member
member
England
Posts: 38
Joined: 21 Nov 2018 23:04

Re: Technics SL-1700 MK2 - Problem with arm return

Post by paddypaws » 10 Nov 2019 12:36

The small gear equivalent is available:

https://uk.farnell.com/huco/101281032fa ... m%2Fsearch

101281032FAR gear part number.

Post Reply