Thorens TD147 Auto Stop - help

snap, crackle and pop
Post Reply
JessePGordon
Posts: 2
Joined: 01 Mar 2014 19:13

Thorens TD147 Auto Stop - help

Post by JessePGordon » 18 Sep 2019 04:15

Hi All:
I have a problem with my TD147 Jubilee. The auto stop doesn't work properly. Since this is one of the reasons I bought this 'table, I really want it to work as designed. So...

The problem started when the LM324 quad op-amp (Z101) fused and took out one of the rectifier diodes in the power supply section. This presented ~20VDC to the whole circuit and cooked the MC3400 JFet op amp (Z102), the BC547a transistor (T101), the 4.7V Zener (D108) and the arm position LED (D109). All of these have now been replaced and the board is behaving just as it should, with one exception. When the arm crosses into the lead-out groove it is supposed to drive the transistor output high which releases the solenoid allowing the arm cue to be in the down position, thus lifting the arm and coincidentally shutting off the motor. With mine, as the cartridge crosses the lead-out groove, nothing happens. However if I move the arm briskly across the same area, the arm cue lifts and the table shuts off as designed.

When repairing the damage described above, I was unable to find an exact replacement LED, so have used a 3mm warm white led with a 3.3k dropping resistor. This seems to be workable although a bit brighter that the original. I can measure the voltage rise on TP4 specified in the service manual, however it doesn't seem to get all the way up to the +15V the manual specifies. It seems to peak around +9V. My meter isn't fast enough to display the voltage when the arm is swung briskly through the lead-out area, but since the auto stop triggers as designed, I must assume that that motion is generating the required voltage to the base of T101 through IC101/3.

Have any of you had / seen / fixed this problem or have any idea what I am missing? I would be deeply grateful for help with this.

Best regards all
Jess

JessePGordon
Posts: 2
Joined: 01 Mar 2014 19:13

Re: Thorens TD147 Auto Stop - help

Post by JessePGordon » 23 Sep 2019 00:11

Nobody have any info on this?

Post Reply