old Linn Sondek doesn't spin!

snap, crackle and pop
Post Reply
yak66
member
member
Posts: 226
Joined: 05 Nov 2014 10:34

old Linn Sondek doesn't spin!

Post by yak66 » 24 Jun 2019 16:10

an old Linn Sondek from 1990 does not spin
the platter does not turn
the pulley of motor makes small steps (1 mm) right and left
(also without belt)
the pulley becomes hot ........ :(
what is the problem?
THANK YOU !

PS has been stopped 20 years !

Chiltern
long player
long player
England
Posts: 1144
Joined: 11 Apr 2008 11:12
Location: West Country, England

Re: old Linn Sondek doesn't spin!

Post by Chiltern » 24 Jun 2019 17:44

Replace the capacitors in the power supply, a simple task.

Lubricate the motor.

Alan
DSCN8214.JPG
(146.49 KiB) Downloaded 80 times

yak66
member
member
Posts: 226
Joined: 05 Nov 2014 10:34

Re: old Linn Sondek doesn't spin!

Post by yak66 » 24 Jun 2019 18:28

Thank you very much Chiltern!
how many are the chances of a broken motor?

Debs
member
member
Northern Ireland
Posts: 108
Joined: 30 Sep 2011 14:25
Location: UK

Re: old Linn Sondek doesn't spin!

Post by Debs » 24 Jun 2019 18:31

If it's from 1990 surely it will have either a Valhalla power supply internally or (late 1990) an external Lingo 1?

I suspect that someone has put the wrong oil in the bearing housing and the lining has swollen. I suspect there's also a problem with the motor thrust pad.

yak66
member
member
Posts: 226
Joined: 05 Nov 2014 10:34

Re: old Linn Sondek doesn't spin!

Post by yak66 » 24 Jun 2019 19:58

LP12 is a SN 81,500 from 1990
probably with Valhalla
the problem is with the belt / platter not connected, (free pulley)

KentT
long player
long player
Posts: 4526
Joined: 13 Mar 2008 19:44
Location: Athens, TN

Re: old Linn Sondek doesn't spin!

Post by KentT » 25 Jun 2019 12:58

Valhalla board bad and/or motor bad. Usually Valhalla boards had problems with age. A good excuse to buy a Lingo board (which is considerably better, and also less wear on the motor). With the Valhalla boards, they were always on. The Lingo is not always on except when you're using the turntable.

Post Reply