main bearing systemdek xe900 - no ball bearing in housing

snap, crackle and pop
Post Reply
davenorm
junior member
junior member
Great Britain
Posts: 8
Joined: 02 Jun 2019 21:36

main bearing systemdek xe900 - no ball bearing in housing

Post by davenorm » 15 Jun 2019 15:31

ok.. thanks everyone for help i e had so far trying to get my systemdek xe900 going again....

it was running slow... ive taken the main bearing housing sleeve off and removed the spindle... the housing is completely dry... and theres nothing inside the bearing housing... no ball bearing, nothing...

so what should be there?.. im guessing a ball bearing?.. some kind of ball bearing seat sitting on the bottom of the housing that contains the ball bearing?.. oil?.. is the whole bearing housing meant to be filled with oil up to the top when the spindle is inside it?... wondering how to fill it without over filling it and it have oil running out when the spindle goes in...

ok.. i guess if youre knowledgeable about this id be very grateful for any info and tips etc
.. thanks

Copperhead
long player
long player
Posts: 1835
Joined: 07 Mar 2015 00:47

Re: main bearing systemdek xe900 - no ball bearing in housing

Post by Copperhead » 16 Jun 2019 00:05

Someone with the same issue here, maybe it will be relevant to you.

https://www.vinylengine.com/turntable_f ... hp?t=21333

Might have been easier if you included all the issues under one thread seeing as it's all related to getting the Sytemdek back in action.

davenorm
junior member
junior member
Great Britain
Posts: 8
Joined: 02 Jun 2019 21:36

Re: main bearing systemdek xe900 - no ball bearing in housing

Post by davenorm » 16 Jun 2019 21:49

ok sorted it... its an 8mm ball bearing that you drop into the main bearing sleeve. the spindle axis has a chamfer on it so that it sits on the ball bearing and the ball bearing self centres on the spindke axis.

thanks for your help

Post Reply