turntable very slow after many years out of use

snap, crackle and pop
Post Reply
davenorm
junior member
junior member
Great Britain
Posts: 8
Joined: 02 Jun 2019 21:36

turntable very slow after many years out of use

Post by davenorm » 14 Jun 2019 12:39

hi im i the process of fixing up my systemdek xe900 turntable... it works fine now but rotation speedis very slow... the turntable has been out of use for years.

i guess the bearing needs lubricating..maybe the belt replacing... how do i get at the bearings an strip them down withot breaking anything

also... is there anything else i ned to do, check or be aware of,

thanks

Alec124c41
vinyl engineer
vinyl engineer
Canada
Posts: 22884
Joined: 28 Oct 2002 03:24
Location: North of Toronto, Canada

Re: turntable very slow after many years out of use

Post by Alec124c41 » 14 Jun 2019 12:54

A couple of drops of sewing machine oil to the top and bottom motor bearings, some fresh oil in the platter bearing, and a new belt should do it.
Old oil does get sticky.

Cheers,
Alec

nat
long player
long player
Posts: 4257
Joined: 07 Nov 2002 19:05

Re: turntable very slow after many years out of use

Post by nat » 14 Jun 2019 22:06

You may have to disassemble the bearing and clean it out, and possibly even the motor, but try Alex's suggestion first, and let's hope that's all it takes.

davenorm
junior member
junior member
Great Britain
Posts: 8
Joined: 02 Jun 2019 21:36

Re: turntable very slow after many years out of use

Post by davenorm » 15 Jun 2019 13:53

thankyou... im now trying to figure out how to access everything inside.... ok cheers

Post Reply