Annoying hum

snap, crackle and pop
Post Reply
nilsje4
Netherlands
Posts: 3
Joined: 16 Feb 2019 02:58

Annoying hum

Post by nilsje4 » 15 May 2019 21:45

Hello everyone,

A few weeks ago i bought some things so i could finally enjoy my record collection.

- Mitsubishi DP-EC8 turntable
- Behringer PP-400 phono pre-amp
- Sansui A5 amplifier

However i'm having some problems with humming noises while using headphones.
I also hear some sort of bleeping noise in the background (for lack of a better word to describe it).
I've tried connecting the setup to my soundbar and strangely enough, i get no hum.

I tried to solve it myself with my poor knowledge of this stuff, but nothing worked. Here's what i tried:
- I connected the turntable to the pre-amp and skipped the Sansui amp. No difference.
- I've tried to remove the pre-amp from the setup and connect straight to the sansui phono input. No difference either.
- I've tried to use a ground loop isolator in each part of the setup (between turntable and pre-amp, between pre-amp and amplifier and between the amplifier and the headphones. No difference.

In the 3 setups mentioned above the sound was still just fine on the soundbar.
I probably should mention that the turntable doesn't have a seperate ground cable for any who would wonder.

I've also used different pairs of headphones just in case the one i used first was faulty in some way.

I'm fairly new to turntables, amplifiers and all that so any help would be appreciated.

Thanks.
Nils

steverose798
junior member
junior member
Posts: 8
Joined: 21 Jan 2017 15:43

Re: Annoying hum

Post by steverose798 » 16 May 2019 19:24

Hi,

Not sure about the hum but the bleeping could be interference from a mobile phone or nearby wifi router. I had this on a Music Centre, all was OK when playing a record but the bleeping happened when playing a tape. I moved the router and the bleeping went away.

Steve

nilsje4
Netherlands
Posts: 3
Joined: 16 Feb 2019 02:58

Re: Annoying hum

Post by nilsje4 » 20 May 2019 20:11

steverose798 wrote:
16 May 2019 19:24
Hi,

Not sure about the hum but the bleeping could be interference from a mobile phone or nearby wifi router. I had this on a Music Centre, all was OK when playing a record but the bleeping happened when playing a tape. I moved the router and the bleeping went away.

Steve
Hi Steve,

Thanks for your reply. I tried putting the turntable in another spot removed from all other devices.
The bleeping did go away. So thank you for that advice!

I'm still looking for the solution to my hum problem.
Any help would be welcome.

Nils

p_m
junior member
junior member
United States of America
Posts: 11
Joined: 20 May 2015 16:34
Location: CA, USA

Re: Annoying hum

Post by p_m » 23 May 2019 22:42

So Turntable->Preamp->Soundbar is no hum ? but in any other combination, regardless of headphone or loudspeaker, you get hum. correct ? I suspect its something to do with your sansui A5 amp, or its grounding scheme.
If you are going to use headphones you might be better off just getting a dedicated headphone amp. There are several great affordable and compact battery operated options.

Post Reply