the home of the turntable

SL-1210GR clicks on arm lift or arm drop?

snap, crackle and pop

SL-1210GR clicks on arm lift or arm drop?

Postby Sterling1 » 16 Jul 2018 14:53

Upon setting tonearm up or down using cue lever, I hear a squeaky clicking sound originating at the parts of the turntable which drop or lift tonearm. Is this clicking sound, ( usually three to five even spaced clicks ) normal? If not can I repair it? This turntable was purchased just a week ago, new from B & H. Other than the clicking sound, the unit works great.
Sterling1
senior member
senior member
 
Posts: 256
Joined: 01 Feb 2017 17:28

United States of America

Re: SL-1210GR clicks on arm lift or arm drop?

Postby audiopile » 16 Jul 2018 17:07

so this is a mechanical noise coming from the lifter mechanism - at the arm base ? If you aren't sure - try buying or borrowing a stethoscope -these are handy for isolating odd noises from equipment.it's not coming thru your speakers ? you might want to try cuing the arm up and down off of a stationary record maybe 20 times -see if this goes away ? My GAE is completely silent and for what it's worth -don't remember ever noticing this on any of the ratty SL-1200 's I've rebuilt ? Might be time to give it back to B&H and go for a replacement -either from them or another dealer. If this were one of my very used 1200's - I probably wouldn't care - but new should start out pretty darn near perfect -it's part of what ya get for the extra money you pay for new.
audiopile
long player
long player
 
Posts: 1879
Joined: 11 Feb 2010 07:48
Location: Milwaukee ,Wi. USA

United States of America

Re: SL-1210GR clicks on arm lift or arm drop?

Postby Sterling1 » 16 Jul 2018 19:26

audiopile wrote:so this is a mechanical noise coming from the lifter mechanism - at the arm base ? If you aren't sure - try buying or borrowing a stethoscope -these are handy for isolating odd noises from equipment.it's not coming thru your speakers ? you might want to try cuing the arm up and down off of a stationary record maybe 20 times -see if this goes away ? My GAE is completely silent and for what it's worth -don't remember ever noticing this on any of the ratty SL-1200 's I've rebuilt ? Might be time to give it back to B&H and go for a replacement -either from them or another dealer. If this were one of my very used 1200's - I probably wouldn't care - but new should start out pretty darn near perfect -it's part of what ya get for the extra money you pay for new.
Thanks for the advice. It made me think that possibly the track mechanism, which the tonearm rests upon, might have some friction, so I licked my finger and got the mechanism somewhat wet. Clicks disappeared. Now, I know where to lube if that's necessary. I guess you could say I think I've got the problem licked. :D
Sterling1
senior member
senior member
 
Posts: 256
Joined: 01 Feb 2017 17:28

United States of America

Return to Turntables and Tonearms