Very low sound with Sherwood PM 9805

snap, crackle and pop
Post Reply
stef7930
Posts: 3
Joined: 05 Dec 2017 13:10

Very low sound with Sherwood PM 9805

Post by stef7930 » 11 Dec 2017 03:25

Hi All,

I recently purchased a Sherwood turntable.

I got a phono pre-amp with which I linked my turntable to a pair of powered speakers:

https://img.alicdn.com/imgextra/imgextr ... 1581960000

https://img.alicdn.com/imgextra/imgextr ... 1581960000

However, the sound output is extremely low :( :( :(

All the connections seem done correctly, though (RCA cables and ground wire).

Any suggestions on what would cause the issue?

thanks in advance.

smeg68
broken record
Posts: 1048
Joined: 15 Jun 2010 05:27

Re: Very low sound with Sherwood PM 9805

Post by smeg68 » 11 Dec 2017 04:39

What cartridge is mounted on the turntable? If it's an MC then you'll need a SUT or head amp to let it work into the phono stage.

stef7930
Posts: 3
Joined: 05 Dec 2017 13:10

Re: Very low sound with Sherwood PM 9805

Post by stef7930 » 11 Dec 2017 04:57

Hi, thanks for the reply!

it's a MM cartridge by Audio Technica.

Here's a picture:

https://drive.google.com/file/d/0Byz1YM ... sp=sharing

Slavikcc
senior member
senior member
Canada
Posts: 592
Joined: 27 Jul 2016 02:26

Re: Very low sound with Sherwood PM 9805

Post by Slavikcc » 11 Dec 2017 15:33

Are your powered speakers working when using another device like say to your tape deck or PC? If it does work, then try using another phono preamp device as it's possible the one you have is dead.

stef7930
Posts: 3
Joined: 05 Dec 2017 13:10

Re: Very low sound with Sherwood PM 9805

Post by stef7930 » 12 Dec 2017 03:56

hi!

Finally, I found out the problem was caused by the speakers themselves. Not sure why, because when using them with another device through bluetooth they worked fine, but when plugging the RCA cable between preamp and speakers they didn't receive the signal.

I switched to another pair of speakers and everything worked like a charm.

Post Reply