Page 1 of 1

TD145 feedback noise

Posted: 22 May 2019 16:51
by easioz
Hoping someone on the forum can advise on my problem. I have a TD145 with Stanton 681EEE cartridge which I bought some years back but had not used as am running a Linn Sondek that my father owned. It is coupled to a Marantz PM7004 amplifier. When I connect the 145 there is a very loud feedback/hum noise. If I run an earth wire from my amp to the metal by the tone arm it dissipates. Does the 145 need an earth, is it the Stanton, or maybe the RCA connectors?

Re: TD145 feedback noise

Posted: 22 May 2019 18:48
by nezbleu
Probably the cables/connectors. The Thorens tables do not have a separate ground wire, the chassis ground is tied to one channel's ground connection, and the connectors are notorious for failing. Cut them both off and solder on new ones and you will likely be good to go. (It is possible that the connection is broken somewhere inside the turntable, but I would start with the RCAs.)

Re: TD145 feedback noise

Posted: 22 May 2019 20:34
by tlscapital
Well I decided while tweaking both my Thorens and SME tonearm that had both a slight hum out of the speakers and mass/static build on the top plate to DIY service it. So I gave it a separate sub & chassis outgoing ground and the tonearm it's own. This should make it easy to trouble shoot in any case... Since, my speakers are dead silent and I can touch the top plate.

Re: TD145 feedback noise

Posted: 22 May 2019 22:03
by JDJX
Yeah the vintage Thorens that do not have a separate ground wire use the right channel RCA ground as the TT ground... ...including the 145.

Thorens used poor RCA plugs that are prone to corrosion and most just replace them with quality ones ..... and problems solved...... good ground and excellent connections for sound. :)
its a good ground system with good plugs .

Strangely you can possibly have a good enough connection for adequate sound but not quite good enough for the TT ground to eliminate hum

BTW, I once had a 145.
When getting back into vinyl, I got a 165 and one of the the first things that I did to it was replace the plugs. :)

Re: TD145 feedback noise

Posted: 23 May 2019 16:23
by easioz
Thank you all for your advice and I will start with the badly corroded RCA connectors and update on the process as and when it occurs.

John

Re: TD145 feedback noise

Posted: 23 May 2019 17:21
by lenjack
Feedback has nothing to do with ground wires. You are getting electrical hum, which is entirely different.

Re: TD145 feedback noise

Posted: 01 Jun 2019 20:51
by hebridean
You can check the connections with a multimeter set to 2000 ohms. Turn the turntable upside down rest it in the lid and take off the bottom. Remove the tonearm to RCA wires connection cover. With the meter blue to outer left RCA connection, white inner left, red inner right and green outer right. You should get a reading of 0.00 and if you do then do the same on the tonearm end to the connector to eliminate a possible fault there. If all reads well then run a bit of wire from the bridge securing screw to the outer main body at the rear where there should be a wire coming from the inner.
I've done this twice on 145's recently which both had noise issues.