technics 1210 mkII shuddering platter problem

turning japanese
Post Reply
danf76
Posts: 2
Joined: 27 Sep 2013 13:50

technics 1210 mkII shuddering platter problem

Post by danf76 » 29 Sep 2013 18:16

20130929_181352.jpg
(314.92 KiB) Downloaded 1633 times
Hi guys. I've recently noticed a problem with my platter shuddering when using my pitch slide. Never noticed this before but the deck has been unused for a couple of years now so maybe it's just happened when I've brought it back out of hibernation!?!

Anyway i thought i might have to replace the pitch control, pcb and all, but then started to read around and it seems the d301 zener diode has been pointed at for these problems. After checking the pitch co whAtntrol pcb everything seems fine (not done a proper electrical test as i can't find my test kit); nothing looking burned out and no broken connections, and my slider still feels great.
I decided to have a look on the mainboard to check out the d301 when i noticed that i had a melt situation going on with D1, C5 & C6 as shown in the picture.
I'm pretty sure this must be the problem!? Problem is i don't know what C5 & C6 are? They're not.listed in the service manual as far as i can see? They have 223k 100 D: written on the capacitors but i have no ideawhat that means. They have no farad info on them and i can't see them listed in any manual?

Any help appreciated, cheers :D

Cobra2
senior member
senior member
Posts: 361
Joined: 25 May 2002 00:00
Location: Stavanger

Re: technics 1210 mkII shuddering platter problem

Post by Cobra2 » 30 Sep 2013 08:51

I think D1 is a rectifier-bridge, and the C5/C6 are noise-damping-caps, most probably ceramic, and the "melted" part is just glue.
Don't worry.

Arne K

OneyedK
long player
long player
Posts: 2074
Joined: 26 Aug 2010 19:48
Location: Mechelen, Belgium

Re: technics 1210 mkII shuddering platter problem

Post by OneyedK » 30 Sep 2013 19:38

Arne is right about the "melting" thingie ;)

With the deck switched of, slide the fader fast up and down 10 times or so.
Switch the deck back on and see if the problem persists.

danf76
Posts: 2
Joined: 27 Sep 2013 13:50

Re: technics 1210 mkII shuddering platter problem

Post by danf76 » 30 Sep 2013 22:40

Thanks for responses guys. looks more like the brown plastic on the capacitors has melted than a glue issue to be honest. tried the pitch control up and down thing too but to no avail. Got me baffled this has! Pitch control feels fine. clicks in middle and green locks. feels smooth with good resistance all the way from -8 to +8.. I guess i'm going to need to electrical test the board. was just hoping someone had experienced the same problem and could advise me how they solved the problem. Cheers anyway guys.

cafe latte
vinyl addict
vinyl addict
Australia
Posts: 11264
Joined: 11 Oct 2009 04:27
Location: Cattle property near Ravenshoe Qld Australia

Re: technics 1210 mkII shuddering platter problem

Post by cafe latte » 03 Oct 2013 01:49

Check the main bearing is free and lubed up, also check it has no play. If the spindle bearing is getting tight it may cause the shudder you are seeing when you change pitch.
Regards
Chris

mechstek
junior member
junior member
Posts: 12
Joined: 30 Jun 2011 01:25
Location: Medicine Hat, AB.

Re: technics 1210 mkII shuddering platter problem

Post by mechstek » 03 Nov 2013 06:03

danf76 wrote:...looks more like the brown plastic on the capacitors has melted than a glue issue to be honest. tried the pitch control up and down thing too but to no avail. Got me baffled this has! Pitch control feels fine. clicks in middle and green locks. feels smooth with good resistance all the way from -8 to +8.. I guess i'm going to need to electrical test the board. was just hoping someone had experienced the same problem and could advise me how they solved the problem. Cheers anyway guys.
Trust the masses: it's just glue. Your zener diode lead is a solid one though: I once replaced one in an SL-1200 with erratic speed issues (regardless of pitch slider position or movement) and problem solved since. I still own and use such table.

lansovacha
Posts: 2
Joined: 01 Jan 2017 05:59

Re: technics 1210 mkII shuddering platter problem

Post by lansovacha » 13 Oct 2019 01:19

Hello
I noticed the C5 and C6 swollen up on my MK5.
Any advice?
Attachments
IMG_20191013_020306.jpg
(235.03 KiB) Downloaded 54 times

lansovacha
Posts: 2
Joined: 01 Jan 2017 05:59

Re: technics 1210 mkII shuddering platter problem

Post by lansovacha » 13 Oct 2019 01:20

Here's how it looks on my M5G
Attachments
IMG_20191013_020720.jpg
(232.55 KiB) Downloaded 56 times

cafe latte
vinyl addict
vinyl addict
Australia
Posts: 11264
Joined: 11 Oct 2009 04:27
Location: Cattle property near Ravenshoe Qld Australia

Re: technics 1210 mkII shuddering platter problem

Post by cafe latte » 13 Oct 2019 09:40

lansovacha wrote:
13 Oct 2019 01:19
Hello
I noticed the C5 and C6 swollen up on my MK5.
Any advice?
They look normal
Chris

Post Reply