technics sl 1500

turning japanese
Post Reply
jable
Posts: 2
Joined: 14 Mar 2010 15:04
Location: Washington D.C.

technics sl 1500

Post by jable » 07 Dec 2012 22:51

Anyone know why this turntable does not hold a constant speed?
is it worth fixing?

Alec124c41
vinyl engineer
vinyl engineer
Canada
Posts: 23144
Joined: 28 Oct 2002 03:24
Location: North of Toronto, Canada

Re: technics sl 1500

Post by Alec124c41 » 08 Dec 2012 02:42

Clean all switches, contacts, adjustable pots, with contact/control cleaner inside them. The thin layer of oxides on the surfaces mess with the conductivity.

Cheers,
Alec

jable
Posts: 2
Joined: 14 Mar 2010 15:04
Location: Washington D.C.

unsteady speed

Post by jable » 09 Dec 2012 15:48

Does anyone know how to repair a Technics turntable that cannot keep a steady speed ?
Is it wort fixing?
Otherwise seems like a good piece. Thanks

Alec124c41
vinyl engineer
vinyl engineer
Canada
Posts: 23144
Joined: 28 Oct 2002 03:24
Location: North of Toronto, Canada

Re: unsteady speed

Post by Alec124c41 » 09 Dec 2012 21:35

jable wrote:Does anyone know how to repair a Technics turntable that cannot keep a steady speed ?
Is it wort fixing?
Otherwise seems like a good piece. Thanks
See above.

Cheers,
Alec

Seth78
junior member
junior member
Posts: 15
Joined: 03 Jun 2018 16:41

Re: technics sl 1500

Post by Seth78 » 28 Sep 2019 22:07

Alec124c41,
I know this is an old thread but I wanted to say thank you. I just got a SL-1500 and speed was an issue. I opened it up and cleaned all switches and put on some deoxit. Works great now!

lenjack
long player
long player
Posts: 2037
Joined: 23 Jun 2017 02:11
Location: Liverpool,PA

Re: technics sl 1500

Post by lenjack » 28 Sep 2019 23:50

Very common problem, and easily remedied.

Post Reply