Technics SP10 MK II packed wrong

turning japanese
Post Reply
harryz
Posts: 2
Joined: 23 Mar 2014 00:35

Technics SP10 MK II packed wrong

Post by harryz » 18 May 2019 05:03

Greetings-
I’m new here and am seeking advice. I recently bought an SP 10 MK 2. The seller had restored the unit and the pictures looked great. He shipped the plinth separately and I’ll receive it next week.

I picked up the turntable from FedEx today. A good friend was with me. The table and power supply were beautifully packed, each in its own box. The seller, who seems knowledgeable and reputable, shipped the table with the platter screwed down and without a protective shipping plate. He said that he removed the platter and packed the screws separately in a bag and isolated the platter with bubble wrap. My friend and I unpacked the table together and this was not the case.

He says that he has owned many of these and none were shipped with the shipping plate, and there has never been a problem. When I received the table, all that was needed was to connect the umbilical to the power supply and put it on some feet for isolation in order to test it. At first it was quiet but quickly lost speed within seconds and made bad rubbing and cogging noises. We checked to see if something was locked down but this was not the case.

I would like to get the table working and not have a hassle with the seller; my sense is that he’s a good guy. I suspect that he forgot to remove the platter; he is older and shared that he has health issues, and perhaps he forgot. Also, the packing looked professional and I’m wondering if he had someone else do it. Anyway, I don’t want this to turn into a fight about return shipping.

So... Is the table salvageable/ fixable? I’m afraid That the bearing may have been damaged in shipping or the motor is now out of alignment, or both… Any advice?

Thanks-

Harry Z
Portland, OR

P4t1n3tt3
member
member
France
Posts: 35
Joined: 10 Nov 2017 04:03

Re: Technics SP10 MK II packed wrong

Post by P4t1n3tt3 » 18 May 2019 08:10

Hello and welcome to the forum.

Always remove the platter from the turntable because during transport, the platter (2.9kg) will hit the spindle with each blow. #-o

I will advise you to make a short video showing the variations of speed and especially the noise and to send it to your seller.

The obvious repair for me would be to replace the engine, still it has to work well once in place.

Good luck and keep us informed of the rest of the business.

JaS
engine room
engine room
Posts: 11265
Joined: 12 Feb 2002 16:32

Re: Technics SP10 MK II packed wrong

Post by JaS » 18 May 2019 08:48

harryz wrote:
18 May 2019 05:03
At first it was quiet but quickly lost speed within seconds and made bad rubbing and cogging noises.
The platter should have been locked down or removed completely, but it doesn't necessarily mean permanent damage has occurred.

From your description of the noise the first thing I'd check is the braking system; as well as an electronic brake, the SP10 uses a solenoid operated brake band. If this has become dislodged, or is badly adjusted or worn it can rub badly. You can easily remove the band to discount it as the cause of the noise - the band and it's adjuster are under the black plate once the platter is taken off.

https://www.vinylengine.com/images/forum/sp10_brake.jpg

If the motor and/or bearing are damaged I'd be tempted to send it back for a refund.

P4t1n3tt3
member
member
France
Posts: 35
Joined: 10 Nov 2017 04:03

Re: Technics SP10 MK II packed wrong

Post by P4t1n3tt3 » 18 May 2019 10:53

JaS had a very good idea. =D>

You can download the "mk2 service manual" and "mk2 instruction/owners manual" to help you access the brake. https://www.vinylengine.com/library/technics/sp10.shtml

harryz
Posts: 2
Joined: 23 Mar 2014 00:35

Re: Technics SP10 MK II packed wrong

Post by harryz » 18 May 2019 20:01

Had a very productive conversation with the seller, who is terrific. We did some troubleshooting and he’s convinced that it’s the brake system. I’m sending it back to him and he’ll fix it. Will not be shipping the platter with the unit:)

Post Reply