Technics SL-5 Inner Groove Distortion Issue

turning japanese
ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 14 Mar 2019 21:02

Hi all. I replaced the cartridge on my SL-5 and ever since then, it plays with really bad distortion when it gets close to the label. The replacement cartridge is an AT85EP. I've tried swapping that stylus and playing it on the old cartridge and it still plays with distortion. I've tried putting the tracking force higher and still no improvement. I put back the old cartridge and stylus back on and it now plays the same too. I don't know what I did for it to all of the sudden to sound like that but I hope I didn't break something while replacing the cartridge. I'm still a bit new to doing this type of stuff and didn't realize all I really needed to do was to replace the stylus. Any help would be appreciated!

paulrenea
member
member
Posts: 68
Joined: 14 Apr 2012 18:35

Re: Technics SL-5 Inner Groove Distortion Issue

Post by paulrenea » 15 Mar 2019 00:36

I also have this SL-5. Are there any cartridge adjustment options to consider? The one I have may be in need of cleaning the rail and re-oiling it. I have to go out, maybe we can chat later-on.

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 16 Mar 2019 03:56

There doesn't seem to be any cartridge adjustment options as far as I know

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 26 Mar 2019 02:37

Is there anyone else who can help me with this?? I've tried different cartridges and needles and yet I still get that awful distorted sound

fscl
vinyl addict
vinyl addict
United States of America
Posts: 7692
Joined: 05 Aug 2004 07:51
Location: CT, US

Re: Technics SL-5 Inner Groove Distortion Issue

Post by fscl » 27 Mar 2019 16:37

Have you tried verifying the tracking force ? Could it be previously ruined inner grooves on the LPs you're playing ?

Fred

Gravitar8
senior member
senior member
Canada
Posts: 451
Joined: 18 Nov 2017 17:07
Contact:

Re: Technics SL-5 Inner Groove Distortion Issue

Post by Gravitar8 » 27 Mar 2019 17:39

Apologies if this is TOO obvious but it does get missed.. have you checked and verified the table is sitting level? I know the SL-15 (though it can be hung and plays quite well vertically too) really needs a rock solid leveling to track properly.

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 28 Mar 2019 15:19

fscl wrote:
27 Mar 2019 16:37
Have you tried verifying the tracking force ? Could it be previously ruined inner grooves on the LPs you're playing ?

Fred
The tracking force is at about 1.5g. The LPs that I have played fine before I tried replacing the cartridge. I've played new records and it has that problem too! This is still a mystery to me I'm not sure if I damaged the part of the tonearm that connect the cartridge to it.

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 28 Mar 2019 15:27

Gravitar8 wrote:
27 Mar 2019 17:39
Apologies if this is TOO obvious but it does get missed.. have you checked and verified the table is sitting level? I know the SL-15 (though it can be hung and plays quite well vertically too) really needs a rock solid leveling to track properly.
It's definitely on sitting level. The table that its on never had a problem tracking at all

fscl
vinyl addict
vinyl addict
United States of America
Posts: 7692
Joined: 05 Aug 2004 07:51
Location: CT, US

Re: Technics SL-5 Inner Groove Distortion Issue

Post by fscl » 28 Mar 2019 15:55

ajames45 wrote:
28 Mar 2019 15:19
fscl wrote:
27 Mar 2019 16:37
Have you tried verifying the tracking force ? Could it be previously ruined inner grooves on the LPs you're playing ?

Fred
The tracking force is at about 1.5g. The LPs that I have played fine before I tried replacing the cartridge. I've played new records and it has that problem too! This is still a mystery to me I'm not sure if I damaged the part of the tonearm that connect the cartridge to it.
:-k :-k :-k

Very perplexing unless you've really torqued the tonearm extracting the previous cartridge. I would try swabbing / cleaning / lubing the pins of the P-Type cartridges with contact cleaner and sliding the cartridge in and out several times.

At what reading / pointer on the linear scale does the IGD start 17CM, 10CM, 8CM...... :-k :-k :-k

Fred

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 28 Mar 2019 18:29

fscl wrote:
28 Mar 2019 15:55
ajames45 wrote:
28 Mar 2019 15:19
fscl wrote:
27 Mar 2019 16:37
Have you tried verifying the tracking force ? Could it be previously ruined inner grooves on the LPs you're playing ?

Fred
The tracking force is at about 1.5g. The LPs that I have played fine before I tried replacing the cartridge. I've played new records and it has that problem too! This is still a mystery to me I'm not sure if I damaged the part of the tonearm that connect the cartridge to it.
:-k :-k :-k

Very perplexing unless you've really torqued the tonearm extracting the previous cartridge. I would try swabbing / cleaning / lubing the pins of the P-Type cartridges with contact cleaner and sliding the cartridge in and out several times.

At what reading / pointer on the linear scale does the IGD start 17CM, 10CM, 8CM...... :-k :-k :-k

Fred
I think I must've twisted the tonearm :( . The IGD starts at about 17cm but with some albums where the voice can get loud (like for a Whitney Houston or Destiny's Child album) it can distort even around the 20-30cm side. Also what contact cleaner would you recommend? I have a feeling I just need try that since the previous cartridge was on there for about 2 years.

Gravitar8
senior member
senior member
Canada
Posts: 451
Joined: 18 Nov 2017 17:07
Contact:

Re: Technics SL-5 Inner Groove Distortion Issue

Post by Gravitar8 » 30 Mar 2019 17:10

The only way to rule out the stylus/cart is to replace with a brand new unused one and retry and see what happens... i think you can find an audio-technica Pmount for under 45$ that will allow you to 'trial and error'. Obv's if the replacement cart/stylus works you know your current stylus/cart is the culprit.

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 30 Mar 2019 21:02

Gravitar8 wrote:
30 Mar 2019 17:10
The only way to rule out the stylus/cart is to replace with a brand new unused one and retry and see what happens... i think you can find an audio-technica Pmount for under 45$ that will allow you to 'trial and error'. Obv's if the replacement cart/stylus works you know your current stylus/cart is the culprit.
I already bought a new stylus/cart (AT85EP) and that played with distortion and then I bought another stylus and swapped around that one with both the new and old cart and they both still play with distortion. I've tried as many replacement stylus/cart as I could and nothing worked :| . I really think it's something with the part of the tonearm that connects the cartridge because ever since I tried replacing the cartridge I've been getting that awful distorted sound.

Gravitar8
senior member
senior member
Canada
Posts: 451
Joined: 18 Nov 2017 17:07
Contact:

Re: Technics SL-5 Inner Groove Distortion Issue

Post by Gravitar8 » 31 Mar 2019 14:11

Hmmm wonder if it's a physical connection problem? IE-- the pins from the cartridge into the receiving holes...could there be a broken pin part in there? Are you able to use high power magnification/lighting and inspect the end of the arm?
[/quote]

I already bought a new stylus/cart (AT85EP) and that played with distortion and then I bought another stylus and swapped around that one with both the new and old cart and they both still play with distortion. I've tried as many replacement stylus/cart as I could and nothing worked :| . I really think it's something with the part of the tonearm that connects the cartridge because ever since I tried replacing the cartridge I've been getting that awful distorted sound.
[/quote]

ajames45
junior member
junior member
Posts: 13
Joined: 04 Mar 2017 00:09

Re: Technics SL-5 Inner Groove Distortion Issue

Post by ajames45 » 31 Mar 2019 20:19

Gravitar8 wrote:
31 Mar 2019 14:11
Hmmm wonder if it's a physical connection problem? IE-- the pins from the cartridge into the receiving holes...could there be a broken pin part in there? Are you able to use high power magnification/lighting and inspect the end of the arm?
Don't have a high powered magnifier unfortunately.... know of any cheap/affordable ones that could work?

Gravitar8
senior member
senior member
Canada
Posts: 451
Joined: 18 Nov 2017 17:07
Contact:

Re: Technics SL-5 Inner Groove Distortion Issue

Post by Gravitar8 » 31 Mar 2019 20:20

Ive had some success with carefully using iphone at max zoom setting, auto focus, light on. you can try that and then view on desktop and get in even closer.
ajames45 wrote:
31 Mar 2019 20:19
Gravitar8 wrote:
31 Mar 2019 14:11
Hmmm wonder if it's a physical connection problem? IE-- the pins from the cartridge into the receiving holes...could there be a broken pin part in there? Are you able to use high power magnification/lighting and inspect the end of the arm?
Don't have a high powered magnifier unfortunately.... know of any cheap/affordable ones that could work?

Post Reply