Technics SL-J2 Not Finding Record

turning japanese
Post Reply
brianfay
junior member
junior member
Posts: 8
Joined: 11 Jan 2017 02:25
Location: Syracuse, NY

Technics SL-J2 Not Finding Record

Post by brianfay » 23 Jan 2017 00:22

I remember reading someone else having this problem but can't find it anywhere, so I apologize ahead of time for the repeat.

My SL-J2 (a week old to me) was playing records fine but now, when I push Start, the tonearm moves to the beginning of the record, seems to lower and then moves all the way across. Most times, it hasn't made contact with the record, but occasionally it will scratch across the record until I go flying over to cue it back up.

I have ordered a new cartridge and stylus and seem to remember that that might be the problem. Is that right? (I'll get the cartridge Tuesday, Jan 24.)

Anything else I should be thinking about in the mean time?

Thank you!

brianfay
junior member
junior member
Posts: 8
Joined: 11 Jan 2017 02:25
Location: Syracuse, NY

Re: Technics SL-J2 Not Finding Record

Post by brianfay » 26 Jan 2017 12:08

I took it into the shop for a thorough cleaning, relube, and adjustment. It turns out that it won't spin at 45 rpm either and all of it felt over my head. I'll get it back in three weeks or so. Sigh.

davespears
Posts: 2
Joined: 18 Feb 2016 15:25

Re: Technics SL-J2 Not Finding Record

Post by davespears » 15 Nov 2018 02:06

I'm having the same issue with my SL-J2, but my needle never drops. Did you ever find out the cause and solution? Thanks.

davespears
Posts: 2
Joined: 18 Feb 2016 15:25

Re: Technics SL-J2 Not Finding Record

Post by davespears » 15 Nov 2018 02:12

brianfay, nevermind. I see from another post that you got rid of the turntable as it did not meet expectations. I fear I might be doing the same with mine.

fscl
vinyl addict
vinyl addict
United States of America
Posts: 7416
Joined: 05 Aug 2004 07:51
Location: CT, US

Re: Technics SL-J2 Not Finding Record

Post by fscl » 13 Dec 2018 15:04

davespears wrote:
15 Nov 2018 02:06
I'm having the same issue with my SL-J2, but my needle never drops. Did you ever find out the cause and solution? Thanks.
davespears wrote:
15 Nov 2018 02:12
brianfay, nevermind. I see from another post that you got rid of the turntable as it did not meet expectations. I fear I might be doing the same with mine.
If you still have the J2, download the instruction and service manual here, the OP has gotten rid of his unit so I missed your post:

https://www.vinylengine.com/library/tec ... l-j2.shtml

With just your description of not dropping, you will have to troubleshoot the cueing solenoid. The solenoid may have given up the ghost or just stuck (dried up / solidified cueing dampening fluid).

Good luck and sorry I missed this the first time.

Fred

Post Reply