Problem with AT LP60's Tonearm

always listening
Post Reply
VinylsBack99
Greece
Posts: 2
Joined: 20 Nov 2018 22:52

Problem with AT LP60's Tonearm

Post by VinylsBack99 » 20 Nov 2018 23:31

Hey everyone, 8 months ago, i decided to get into vinyl. I decided to pick up the Audio Technica LP60 as my first turntable, mostly because of its quality for its (cheap) price. I was super happy and excited about my choice until yesterday, when i noticed a problem. At first I thought it had to do with my stylus, but upon closer inspection , I realised that suddenly, my tonearm wouldn't go all the way down for the needle to get in the grooves. Like it just stands above the spinning record, and when it occasionally comes down enough for a brief second, I just hear a sound from the record that's playing and that's it. (The thing is, I don't even know how that happened, I was always very careful when I was using the TT. Some people suggest that the tracking force somehow just got lowered on its own.) Now i know that i can't readjust the weight of the tonearm, as it is factory set, so I would like to know if there is any way, in order to fix it. Thanks for your time and replies in advance

lenjack
long player
long player
Posts: 1514
Joined: 23 Jun 2017 02:11
Location: Liverpool,PA

Re: Problem with AT LP60's Tonearm

Post by lenjack » 21 Nov 2018 02:33

If it's new, it should be under warranty. Contact AT service for info. They may give you troubleshooting advice. I suspect they may need to replace the unit under warranty.

BMRR
vinyl addict
vinyl addict
United States of America
Posts: 5522
Joined: 23 Aug 2013 03:48
Location: Maine, USA

Re: Problem with AT LP60's Tonearm

Post by BMRR » 21 Nov 2018 18:15

Check the arm lift button on the front of the turntable (marked with a 3 in the diagram below). Make sure it isn't in the wrong position or that it hasn't become stuck. Try pressing it in and out a few times.
Attachments
Screen Shot 2018-11-21 at 13.14.15.png
(83.7 KiB) Downloaded 54 times

VinylsBack99
Greece
Posts: 2
Joined: 20 Nov 2018 22:52

Re: Problem with AT LP60's Tonearm

Post by VinylsBack99 » 21 Nov 2018 19:36

Thank you all for your replies, I contacted the suppport and I'm gonna have a full refund. ''BMRR'' , the arm lift button functions as it is supposed to, it surely wasn't what caused the problem.

lenjack
long player
long player
Posts: 1514
Joined: 23 Jun 2017 02:11
Location: Liverpool,PA

Re: Problem with AT LP60's Tonearm

Post by lenjack » 21 Nov 2018 23:13

Plain and simple. you should never have to fix anything that is still under warranty.

Post Reply