the home of the turntable

Dual 1229 platter noise

twice the fun

Dual 1229 platter noise

Postby aroo69 » 23 Feb 2013 22:03

Hello everyone! Happy to find this nice forum and post my first thread!
As a beginner I've just got my first turntable, the Dual 1229, since the cartridge needs to be replaced, I leave the tonearm aside for the moment and have just tested the function of the platter, although I heard that the idler drive has a kind of "noise" relatively lounder that we should be used to, I have no idea of how this noise should be like normal, due to lack of comparison. In fact, when my turntable is spinning, it sounds like the outer circle at the bottom of the platter is rubbing the chassis, making a sound noisy enough that I think abnormal. When I take away the heavy platter and test the spinning again, I find the sound of the running motor and the idle wheel themselves are actually very quiet, so I wonder is there something wrong with the installation of my platter? I don't know if it should be lifted a little bit in order to avoid the rubbing, or it's normal as it is. Have you got any idea of my problem? Thank you a lot:)
aroo69
junior member
junior member
 
Posts: 5
Joined: 13 Dec 2012 20:36

Re: Dual 1229 platter noise

Postby rjsilva » 24 Feb 2013 03:28

Assuming you've already looked for anything that might be causing the sound and found nothing, it could be that the platter bearings need some cleaning and/or lubrication. As a test, you could take off the platter and look for the bearings at the bottom of the platter shaft thingy. The bearings should be covered but you can put a few drops of oil on the inside edges and it should work its way into the bearings.

See what happens. I guess the next step would be to actually disassemble the bearings and give them a good clean and lube. It's not hard to do, though getting them out is more elaborate than it should be.
rjsilva
member
member
 
Posts: 133
Joined: 28 Aug 2009 03:11
Location: PA

United States of America

Re: Dual 1229 platter noise

Postby aroo69 » 24 Feb 2013 21:49

Problem solved after cleaning the platter bearing and readjusting the 3 hold-down screws, one of which was kind of bent during the transportation. Now the platter spins without rubbing the chassis, and thus the annoying sound disappear. Many thanks!
aroo69
junior member
junior member
 
Posts: 5
Joined: 13 Dec 2012 20:36

Return to Dual Forum


Design and Content © Vinyl Engine 2002-2014

faq | site policy | advertising