Technics 1200 spins like crazy

turning japanese
Post Reply
jochgem1
junior member
junior member
Posts: 10
Joined: 27 Dec 2011 08:46

Technics 1200 spins like crazy

Post by jochgem1 » 13 Jan 2020 17:43

Hi.
I have 2 1200s. Sometimes when I start them they start spinning like hell.
And both 45/33 lights are on when they do that.
Any tips? I’m quite handy and know where to look if I am pointed in the right direction;)
Thanks in advance
Jochgem

scho2684
long player
long player
Posts: 1883
Joined: 06 Nov 2008 21:24
Location: the Netherlands

Re: Technics 1200 spins like crazy

Post by scho2684 » 13 Jan 2020 17:51

MK2 I assume?
Pretty weird that both tables having the same problem...

Are they build into some cabinet?
I would start looking at the power supply first, and when all that is okay then it looks like both need a new PCB
Most likely the speed control IC (AN6680) has gone, and that could be due to failing capacitors.
Better replace the complete board, and you might want to replace the capacitors on the replacement boards first.

That, unless someone has a better idea...

jochgem1
junior member
junior member
Posts: 10
Joined: 27 Dec 2011 08:46

Re: Technics 1200 spins like crazy

Post by jochgem1 » 13 Jan 2020 17:59

They are built in some cabinet. Where there is I think a power box with such a red button. What can go wrong with that? I thought I solved the problem ones before and after testing it at home it seems gone. And then it came back after a while.

jochgem1
junior member
junior member
Posts: 10
Joined: 27 Dec 2011 08:46

Re: Technics 1200 spins like crazy

Post by jochgem1 » 13 Jan 2020 18:01

It stops after restarting a few times and then they run normally. If I want to check the power supply it’s as simple as just put them directly in the wall and try it a few times?

scho2684
long player
long player
Posts: 1883
Joined: 06 Nov 2008 21:24
Location: the Netherlands

Re: Technics 1200 spins like crazy

Post by scho2684 » 13 Jan 2020 18:41

Yes, plug them into the wall and see if you encounter the same problem...
Its pretty weird that both tables having the same problem at the same time, that is just too much of a coincident not to look at their shared properties first...

jochgem1
junior member
junior member
Posts: 10
Joined: 27 Dec 2011 08:46

Re: Technics 1200 spins like crazy

Post by jochgem1 » 13 Jan 2020 19:49

Will do thanks.

sylvain999
senior member
senior member
Posts: 375
Joined: 10 Mar 2012 22:51
Location: Blainville Quebec

Re: Technics 1200 spins like crazy

Post by sylvain999 » 16 Jan 2020 14:49

scho2684 wrote:
13 Jan 2020 17:51
MK2 I assume?
Pretty weird that both tables having the same problem...

Are they build into some cabinet?
I would start looking at the power supply first, and when all that is okay then it looks like both need a new PCB
Most likely the speed control IC (AN6680) has gone, and that could be due to failing capacitors.
Better replace the complete board, and you might want to replace the capacitors on the replacement boards first.

That, unless someone has a better idea...
If you ever need boards i have a few late model used in stock. All tested good but if you want them full recapped i can do that too.

jochgem1
junior member
junior member
Posts: 10
Joined: 27 Dec 2011 08:46

Re: Technics 1200 spins like crazy

Post by jochgem1 » 16 Jan 2020 15:01

thanks for the tip.
I'm in Amsterdam though.......

sylvain999
senior member
senior member
Posts: 375
Joined: 10 Mar 2012 22:51
Location: Blainville Quebec

Re: Technics 1200 spins like crazy

Post by sylvain999 » 22 Jan 2020 18:53

https://www.green-vinyl.com/en/technics ... page7.html

Then this is the place nearest you that can help you. I'm from Canada, and order from there when i can't find parts anywhere else!

Post Reply