Need help repairing Technics sl-7

turning japanese
Post Reply
sar8
member
member
Posts: 46
Joined: 12 May 2013 21:28

Need help repairing Technics sl-7

Post by sar8 » 01 Jan 2020 17:33

Hello,
Is there anybody familiar with the TT?
and who could advise me upon what to do.
It is as if smth blocked the tonearm ...
I have service manual.

Thank you very much

Serge

fscl
vinyl addict
vinyl addict
United States of America
Posts: 7817
Joined: 05 Aug 2004 07:51
Location: CT, US

Re: Need help repairing Technics sl-7

Post by fscl » 04 Jan 2020 17:22

Both owners and service manuals can be downloaded from the VE library.

This topic should address most all troubleshooting for the SL-7

viewtopic.php?f=16&t=23432

In a nutshell, remove old grease, renew with modern lubricants and replace the tonearm drive belt.

Good Luck

Fred

Cobra2
senior member
senior member
Posts: 364
Joined: 25 May 2002 00:00
Location: Stavanger

Re: Need help repairing Technics sl-7

Post by Cobra2 » 18 Jan 2020 08:28

SL-7 under/inside the cover:
Attachments
IMG_3451.JPG
(180.14 KiB) Downloaded 39 times

sar8
member
member
Posts: 46
Joined: 12 May 2013 21:28

Re: Need help repairing Technics sl-7

Post by sar8 » 18 Jan 2020 08:41

Thank you very much for the photo.
I will see to it today
and will write you back.

have a very good day
Serge

sar8
member
member
Posts: 46
Joined: 12 May 2013 21:28

Re: Need help repairing Technics sl-7

Post by sar8 » 19 Jan 2020 11:07

Hello;
I saw to it yesterday and
I solved the problem, it works now:-)
In short,
I put B to A ( how it should be normally )
and that is all
all electronics work perfectly.

Thank you very much
Attachments
sl-7-2х.jpg
(137.35 KiB) Downloaded 25 times

Post Reply